summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--.travis.yml4
-rw-r--r--docs/versionhistory.rst1
-rw-r--r--setup.py2
-rw-r--r--tox.ini2
4 files changed, 3 insertions, 6 deletions
diff --git a/.travis.yml b/.travis.yml
index ffb49ac..43b7792 100644
--- a/.travis.yml
+++ b/.travis.yml
@@ -32,10 +32,6 @@ jobs:
python: "2.7"
- <<: *test
- env: TOXENV=py34
- python: "3.4"
-
- - <<: *test
env: TOXENV=py35
python: "3.5"
diff --git a/docs/versionhistory.rst b/docs/versionhistory.rst
index 8c5d552..1d0e505 100644
--- a/docs/versionhistory.rst
+++ b/docs/versionhistory.rst
@@ -7,6 +7,7 @@ APScheduler, see the :doc:`migration section <migration>`.
**UNRELEASED**
--------------
+* Dropped support for Python 3.4
* Fixed Zookeeper job store using backslashes instead of forward slashes for paths
on Windows (PR by Laurel-rao)
* Pinned ``tzlocal`` to a version compatible with pytz
diff --git a/setup.py b/setup.py
index e4852a6..e0328dd 100644
--- a/setup.py
+++ b/setup.py
@@ -26,7 +26,6 @@ setup(
'Programming Language :: Python',
'Programming Language :: Python :: 2.7',
'Programming Language :: Python :: 3',
- 'Programming Language :: Python :: 3.4',
'Programming Language :: Python :: 3.5',
'Programming Language :: Python :: 3.6',
'Programming Language :: Python :: 3.7'
@@ -34,6 +33,7 @@ setup(
keywords='scheduling cron',
license='MIT',
packages=find_packages(exclude=['tests']),
+ python_requires='>=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*, !=3.4.*, <4',
setup_requires=[
'setuptools_scm'
],
diff --git a/tox.ini b/tox.ini
index ae4a45d..f4c531b 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,5 +1,5 @@
[tox]
-envlist = py27, py34, py35, py36, py37, pypy, pypy3, flake8
+envlist = py27, py35, py36, py37, pypy, pypy3, flake8
skip_missing_interpreters = true
[testenv]