summaryrefslogtreecommitdiff
path: root/tox.ini
diff options
context:
space:
mode:
authorAlex Grönholm <alex.gronholm@nextday.fi>2022-01-02 15:25:38 +0200
committerAlex Grönholm <alex.gronholm@nextday.fi>2022-01-02 15:25:38 +0200
commita0e1647117225b10e3ee96f9a895ecf2fea40eaf (patch)
tree216cba565b7fb9d1e0ecc49cb3bce6c99dc73fb9 /tox.ini
parentab8c32e0a925b6dff2974f32f645c839cdb000e0 (diff)
downloadapscheduler-a0e1647117225b10e3ee96f9a895ecf2fea40eaf.tar.gz
Upgraded syntax and switched linting over to pre-commit.ci
Linting checks are now run by pre-commit.ci instead of GitHub Actions.
Diffstat (limited to 'tox.ini')
-rw-r--r--tox.ini17
1 files changed, 4 insertions, 13 deletions
diff --git a/tox.ini b/tox.ini
index 956a193..26a882e 100644
--- a/tox.ini
+++ b/tox.ini
@@ -9,19 +9,10 @@ commands = coverage run -m pytest {posargs}
extras = test
[testenv:lint]
-deps =
- isort
- autopep8
-commands =
- autopep8 -r -i src tests
- isort src tests
-skip_install = true
-
-[testenv:flake8]
-basepython = python3.7
-depends = lint
-deps = pyproject-flake8
-commands = pflake8 src tests
+depends =
+basepython = python3
+deps = pre-commit
+commands = pre-commit run --all-files --show-diff-on-failure
skip_install = true
[testenv:mypy]