summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Grönholm <alex.gronholm@nextday.fi>2020-09-26 23:51:01 +0300
committerAlex Grönholm <alex.gronholm@nextday.fi>2020-09-27 01:06:44 +0300
commitb773c79ac5055dc427f09c9452f34fa72a457f90 (patch)
tree72134363adb593af4c7dc4a67fe0207f22e12d85
parent1aca4fad6c8c4cebe4ab71f694abb59a8e502904 (diff)
downloadapscheduler-b773c79ac5055dc427f09c9452f34fa72a457f90.tar.gz
Pinned tzlocal version to < 3.0
The tzlocal major update breaks backwards compatibility. Fixes #461.
-rw-r--r--docs/versionhistory.rst1
-rw-r--r--setup.py2
2 files changed, 2 insertions, 1 deletions
diff --git a/docs/versionhistory.rst b/docs/versionhistory.rst
index 4c106cd..6476ef1 100644
--- a/docs/versionhistory.rst
+++ b/docs/versionhistory.rst
@@ -9,6 +9,7 @@ APScheduler, see the :doc:`migration section <migration>`.
* Fixed Zookeeper job store using backslashes instead of forward slashes for paths
on Windows (PR by Laurel-rao)
+* Pinned ``tzlocal`` to a version compatible with pytz
3.6.3
diff --git a/setup.py b/setup.py
index f195542..65ce612 100644
--- a/setup.py
+++ b/setup.py
@@ -41,7 +41,7 @@ setup(
'setuptools >= 0.7',
'six >= 1.4.0',
'pytz',
- 'tzlocal >= 1.2',
+ 'tzlocal ~= 2.0',
],
extras_require={
':python_version == "2.7"': ['futures', 'funcsigs'],