summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNikita Melentev <multisosnooley@gmail.com>2018-11-29 15:19:19 +0300
committerAlex Grönholm <alex.gronholm@nextday.fi>2018-11-29 14:19:19 +0200
commitabff5f7b3a1099ce5b444ab02708a393e595c425 (patch)
tree157c136be0b32d912ec41766cd24779043f2bbca
parentc866fd618bf0a343fa0dc1a25e86e9ee5f844c63 (diff)
downloadapscheduler-abff5f7b3a1099ce5b444ab02708a393e595c425.tar.gz
Added the API reference to the side bar (#345)
Fixes #343.
-rw-r--r--.gitignore1
-rw-r--r--.readthedocs.yml1
-rw-r--r--docs/conf.py2
-rw-r--r--docs/index.rst7
-rw-r--r--docs/py-modindex.rst2
-rw-r--r--setup.py6
6 files changed, 11 insertions, 8 deletions
diff --git a/.gitignore b/.gitignore
index b4034b9..de34dd5 100644
--- a/.gitignore
+++ b/.gitignore
@@ -4,6 +4,7 @@
.coverage
.cache/
.tox/
+.eggs/
*.egg-info/
*.pyc
dist/
diff --git a/.readthedocs.yml b/.readthedocs.yml
index 9c2c6a6..fc277de 100644
--- a/.readthedocs.yml
+++ b/.readthedocs.yml
@@ -11,3 +11,4 @@ python:
- tornado
- twisted
- zookeeper
+ - doc
diff --git a/docs/conf.py b/docs/conf.py
index 756848c..38eb45b 100644
--- a/docs/conf.py
+++ b/docs/conf.py
@@ -92,7 +92,7 @@ autodoc_member_order = 'alphabetical'
# The theme to use for HTML and HTML Help pages. Major themes that come with
# Sphinx are currently 'default' and 'sphinxdoc'.
-html_theme = 'default'
+html_theme = 'sphinx_rtd_theme'
# Theme options are theme-specific and customize the look and feel of a theme
# further. For a list of options available for each theme, see the
diff --git a/docs/index.rst b/docs/index.rst
index 1dd1c0f..e8ed2da 100644
--- a/docs/index.rst
+++ b/docs/index.rst
@@ -17,9 +17,4 @@ Table of Contents
contributing
extending
faq
-
-
-Indices and tables
-==================
-
-* :ref:`API reference <modindex>`
+ py-modindex
diff --git a/docs/py-modindex.rst b/docs/py-modindex.rst
new file mode 100644
index 0000000..3cdb8ca
--- /dev/null
+++ b/docs/py-modindex.rst
@@ -0,0 +1,2 @@
+API reference
+=============
diff --git a/setup.py b/setup.py
index fbd7765..5d3a686 100644
--- a/setup.py
+++ b/setup.py
@@ -61,7 +61,11 @@ setup(
],
'testing:python_version == "2.7"': ['mock'],
'testing:python_version == "3.4"': ['pytest_asyncio < 0.6'],
- 'testing:python_version >= "3.5"': ['pytest_asyncio']
+ 'testing:python_version >= "3.5"': ['pytest_asyncio'],
+ 'doc': [
+ 'sphinx',
+ 'sphinx-rtd-theme',
+ ],
},
zip_safe=False,
entry_points={