summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Grönholm <alex.gronholm@nextday.fi>2018-08-15 22:03:38 +0300
committerAlex Grönholm <alex.gronholm@nextday.fi>2018-08-15 22:03:38 +0300
commit5d0051517cb7ddc8a33d63e81e68ecd35866b83f (patch)
treeae6f45c97b3f88818f8c488725ba2e1d7180e2af
parentd18a4ec696e590688cf2cb1e7024f974a5229342 (diff)
downloadapscheduler-5d0051517cb7ddc8a33d63e81e68ecd35866b83f.tar.gz
Fixed test suite not running on Python 3.4
-rw-r--r--setup.py3
1 files changed, 2 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 3fc5ba9..fbd7765 100644
--- a/setup.py
+++ b/setup.py
@@ -60,7 +60,8 @@ setup(
'pytest-tornado5'
],
'testing:python_version == "2.7"': ['mock'],
- 'testing:python_version != "2.7"': ['pytest_asyncio']
+ 'testing:python_version == "3.4"': ['pytest_asyncio < 0.6'],
+ 'testing:python_version >= "3.5"': ['pytest_asyncio']
},
zip_safe=False,
entry_points={