summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Grönholm <alex.gronholm@nextday.fi>2016-11-05 23:52:01 +0200
committerAlex Grönholm <alex.gronholm@nextday.fi>2016-11-05 23:57:16 +0200
commit0802351ef10e37fa82ed2da76fa25779c5f87ee3 (patch)
treea834295e6e32e90844a41590da09d2d9c2c7481a
parent0175fdbbb4f688edc48512aa2006226c145918d1 (diff)
downloadapscheduler-0802351ef10e37fa82ed2da76fa25779c5f87ee3.tar.gz
Moved testing dependencies to extras from tox.ini
-rw-r--r--setup.py16
-rw-r--r--tox.ini20
2 files changed, 19 insertions, 17 deletions
diff --git a/setup.py b/setup.py
index 916e791..1676ffc 100644
--- a/setup.py
+++ b/setup.py
@@ -47,13 +47,21 @@ setup(
'asyncio:python_version == "2.7"': ['trollius'],
'asyncio:python_version == "3.3"': ['asyncio'],
'gevent': ['gevent'],
- 'twisted': ['twisted'],
- 'sqlalchemy': ['sqlalchemy >= 0.8'],
'mongodb': ['pymongo >= 2.8'],
- 'rethinkdb': ['rethinkdb'],
'redis': ['redis'],
+ 'rethinkdb': ['rethinkdb'],
+ 'sqlalchemy': ['sqlalchemy >= 0.8'],
'tornado': ['tornado >= 4.3'],
- 'zookeeper': ['kazoo']
+ 'twisted': ['twisted'],
+ 'zookeeper': ['kazoo'],
+ 'testing': [
+ 'pytest',
+ 'pytest-cov',
+ 'pytest-catchlog',
+ 'pytest-tornado'
+ ],
+ 'testing:python_version == "2.7"': ['mock'],
+ 'testing:python_version != "2.7"': ['pytest_asyncio']
},
zip_safe=False,
entry_points={
diff --git a/tox.ini b/tox.ini
index f3653a0..6ee4d1e 100644
--- a/tox.ini
+++ b/tox.ini
@@ -11,23 +11,17 @@ pypy = pypy
[testenv]
commands = pytest {posargs}
-deps = pytest
- pytest-cov
- pytest-catchlog
- pytest-tornado
- sqlalchemy
- pymongo
- kazoo
+extras = testing
+ asyncio
+ gevent
+ mongodb
redis
rethinkdb
+ sqlalchemy
tornado
twisted
- gevent
- {py27,pypy}: mock
- {py27,pypy}: trollius
- {py33}: asyncio
- {py33,py34,py35}: pytest-asyncio
- {py35}: PyQt5
+ zookeeper
+deps = {py35}: PyQt5
[testenv:flake8]
deps = flake8