summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Grönholm <alex.gronholm@nextday.fi>2021-10-10 22:32:42 +0300
committerAlex Grönholm <alex.gronholm@nextday.fi>2021-10-10 22:33:02 +0300
commit6152c3db19ef08ce4e3bca3e75c96809e4a0d22c (patch)
tree62e35a96d06d3c7af6de7fde9ee9781f899f8578
parent71c698053524b8d0da52970ddeefa65fb764023d (diff)
downloadapscheduler-6152c3db19ef08ce4e3bca3e75c96809e4a0d22c.tar.gz
Allowed tzlocal v4+ in addition to v2
Fixes #554.
-rw-r--r--docs/versionhistory.rst6
-rw-r--r--setup.py2
2 files changed, 7 insertions, 1 deletions
diff --git a/docs/versionhistory.rst b/docs/versionhistory.rst
index d17efcc..17eac50 100644
--- a/docs/versionhistory.rst
+++ b/docs/versionhistory.rst
@@ -4,6 +4,12 @@ Version history
To find out how to migrate your application from a previous version of
APScheduler, see the :doc:`migration section <migration>`.
+UNRELEASED
+----------
+
+* Allowed the use of tzlocal v4.0+ in addition to v2.*
+
+
3.8.0
-----
diff --git a/setup.py b/setup.py
index a33213f..3d65227 100644
--- a/setup.py
+++ b/setup.py
@@ -41,7 +41,7 @@ setup(
'setuptools >= 0.7',
'six >= 1.4.0',
'pytz',
- 'tzlocal ~= 2.0',
+ 'tzlocal >= 2.0, != 3.*'
],
extras_require={
':python_version == "2.7"': ['futures'],