summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Grönholm <alex.gronholm@nextday.fi>2021-11-04 22:23:38 +0200
committerAlex Grönholm <alex.gronholm@nextday.fi>2021-11-04 22:50:56 +0200
commit4ded0dceb05acc95b8ef14cfe397e91391a5d39a (patch)
tree86b0be0d869130d19ae13db969e787c2a8b7a94a
parentfc5c361dd9978c593b82125028119a358790048d (diff)
downloadapscheduler-4ded0dceb05acc95b8ef14cfe397e91391a5d39a.tar.gz
Replaced Travis CI with Github Actions
-rw-r--r--.github/workflows/codeqa_test.yaml48
-rw-r--r--.travis.yml61
-rw-r--r--setup.py2
3 files changed, 49 insertions, 62 deletions
diff --git a/.github/workflows/codeqa_test.yaml b/.github/workflows/codeqa_test.yaml
new file mode 100644
index 0000000..e773b8d
--- /dev/null
+++ b/.github/workflows/codeqa_test.yaml
@@ -0,0 +1,48 @@
+name: Python codeqa/test
+
+on:
+ push:
+ branches: [3.x]
+ pull_request:
+
+jobs:
+ lint:
+ runs-on: ubuntu-latest
+ steps:
+ - uses: actions/checkout@v2
+ - name: Set up Python
+ uses: actions/setup-python@v2
+ with:
+ python-version: 3.x
+ - uses: actions/cache@v2
+ with:
+ path: ~/.cache/pip
+ key: pip-lint
+ - name: Install dependencies
+ run: pip install tox
+ - name: Run flake8
+ run: tox -e flake8
+
+ test-linux:
+ needs: [lint]
+ strategy:
+ fail-fast: false
+ matrix:
+ python-version: ["3.6", "3.9"]
+ runs-on: ubuntu-latest
+ steps:
+ - uses: actions/checkout@v2
+ - name: Set up Python ${{ matrix.python-version }}
+ uses: actions/setup-python@v2
+ with:
+ python-version: ${{ matrix.python-version }}
+ - uses: actions/cache@v2
+ with:
+ path: ~/.cache/pip
+ key: pip-test-${{ matrix.python-version }}-ubuntu-latest
+ - name: Start external services
+ run: docker-compose up -d
+ - name: Install the project and its dependencies
+ run: pip install -e .[testing,asyncio,gevent,mongodb,redis,rethinkdb,sqlalchemy,tornado,twisted,zookeeper]
+ - name: Test with pytest
+ run: pytest
diff --git a/.travis.yml b/.travis.yml
deleted file mode 100644
index a60e668..0000000
--- a/.travis.yml
+++ /dev/null
@@ -1,61 +0,0 @@
-dist: xenial
-language: python
-cache: pip
-python: "3.6"
-
-stages:
- - name: static analysis
- - name: test
- - name: deploy to pypi
- if: type = push AND tag =~ ^v\d+\.\d+\.\d+
-
-jobs:
- include:
- - stage: static analysis
- env: TOXENV=flake8
-
- - &test
- stage: test
- env: TOXENV=pypy3
- python: pypy3
- before_install: docker-compose up -d
- after_success:
- - pip install coveralls
- - coveralls
-
- - <<: *test
- env: TOXENV=py27
- python: "2.7"
-
- - <<: *test
- env: TOXENV=py35
- python: "3.5"
-
- - <<: *test
- env: TOXENV=py36
- python: "3.6"
-
- - <<: *test
- env: TOXENV=py37
- python: "3.7"
-
- - stage: deploy to pypi
- install: true
- script: skip
- deploy:
- provider: pypi
- user: agronholm
- password:
- secure: YXuMMv+Ukr49mhiMzy8+bXDilRo52y6YrEzxlLnEksLlq0BNjgRcAsiDzo46k6xuxGxo7XsWaGEP6TBPwTR6eVgmWKjEPrnqyQepRV9Ibrw7+V7DzJn4pBZWX9Pg2oe3WMlYhooIvy6tRDfSaB8cc06/k0ftSNbzAjzpeVk8k0VyLRsBRBqOsrnzvqlRNOUWi0dlgGqhZvGkDMpmi+WVv6rW3y/VaV+vRK88luKHXUy48eMEGPnL3xCgr727es5qmAP9fDKVGKpXvpGzZyRoeMor2HQwj5AFt9DH4YoBbzJRJESSgI4DugtgGPG7Uz1Xx+TxZY609UbR1kju00Vl1KsnGBsxvR0okmItcTzIgp1IRg8MVDGc+duD3oCjlFQEynJL/RExY/yTQfN5rJFtV6nrHrMVgaL2N2dEVFV8zxGvmrptKRq2ujuJ5t2ssMkKAwXRxg2wXQwCjrxUDRMWd7VfRgGadTTdM6TzoeMo8vlL2FA/RvcFVSnfItrSS4ip2FyswzevVyCQMdblLlnlwFG5YTKMAfljd7JzkyA02IND/nFXGcJ3BsP4ciOXoa49PvD+qbNwqL+6v8I5wCYfPlpqfpf9um2SLDYDE6Ka44p1MvnF3me3oaegt2SX92eDvkZN1TICdOxQuvTTGEx7pW8wJS3opBVaQ7Pes5PHO60=
- distributions: sdist bdist_wheel
- on:
- tags: true
-
-install: pip install tox
-
-script: tox
-
-notifications:
- webhooks:
- urls:
- - https://webhooks.gitter.im/e/f41346c0f7c22d4fe002
diff --git a/setup.py b/setup.py
index 3d65227..eda690e 100644
--- a/setup.py
+++ b/setup.py
@@ -56,7 +56,7 @@ setup(
'twisted': ['twisted'],
'zookeeper': ['kazoo'],
'testing': [
- 'pytest < 6',
+ 'pytest',
'pytest-cov',
'pytest-tornado5'
],