summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Grönholm <alex.gronholm@nextday.fi>2015-03-09 01:38:15 +0200
committerAlex Grönholm <alex.gronholm@nextday.fi>2015-03-09 01:42:30 +0200
commitb0e6fe6a21a03415c7fd422ea8e744daa8f1a14b (patch)
treee66da4ae30d3ee3b7e7809388bd17550c48dbc03
parent9364bd36b40a4d6de54cf161208bb240e3fdb445 (diff)
downloadapscheduler-b0e6fe6a21a03415c7fd422ea8e744daa8f1a14b.tar.gz
Require a new enough version of setuptools for entry points to work properly
-rw-r--r--docs/versionhistory.rst2
-rw-r--r--setup.py2
2 files changed, 3 insertions, 1 deletions
diff --git a/docs/versionhistory.rst b/docs/versionhistory.rst
index 5663e19..01d93b4 100644
--- a/docs/versionhistory.rst
+++ b/docs/versionhistory.rst
@@ -16,6 +16,8 @@ APScheduler, see the :doc:`migration section <migration>`.
* Fixed AttributeError when printing a job list when there were pending jobs
+* Added setuptools as an explicit requirement in install requirements
+
3.0.1
-----
diff --git a/setup.py b/setup.py
index 711a1a3..9ea7eec 100644
--- a/setup.py
+++ b/setup.py
@@ -50,7 +50,7 @@ setup(
keywords='scheduling cron',
license='MIT',
packages=find_packages(exclude=['tests']),
- install_requires=['six >= 1.4.0', 'pytz', 'tzlocal'] + extra_requirements,
+ install_requires=['setuptools >= 0.7', 'six >= 1.4.0', 'pytz', 'tzlocal'] + extra_requirements,
tests_require=['pytest >= 2.5.1'],
cmdclass={'test': PyTest},
zip_safe=False,