summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Grönholm <alex.gronholm@nextday.fi>2016-03-27 17:43:42 +0300
committerAlex Grönholm <alex.gronholm@nextday.fi>2016-03-30 09:27:38 +0300
commit9b8dada012a58acbfb3750e125bd43b77aa65ebc (patch)
tree73228b4ab571f0dc591eae30c2cd858650ba7b52
parent673bdcd771026afeea20814964505b7419a39154 (diff)
downloadapscheduler-9b8dada012a58acbfb3750e125bd43b77aa65ebc.tar.gz
Migrated code to Github
-rw-r--r--README.rst5
-rw-r--r--docs/contributing.rst6
-rw-r--r--docs/modules/jobstores/memory.rst2
-rw-r--r--docs/modules/jobstores/mongodb.rst2
-rw-r--r--docs/modules/jobstores/redis.rst2
-rw-r--r--docs/modules/jobstores/sqlalchemy.rst2
-rw-r--r--docs/modules/schedulers/asyncio.rst2
-rw-r--r--docs/modules/schedulers/background.rst2
-rw-r--r--docs/modules/schedulers/blocking.rst2
-rw-r--r--docs/modules/schedulers/gevent.rst2
-rw-r--r--docs/modules/schedulers/qt.rst2
-rw-r--r--docs/modules/schedulers/tornado.rst2
-rw-r--r--docs/modules/schedulers/twisted.rst2
-rw-r--r--docs/userguide.rst2
-rw-r--r--setup.py2
15 files changed, 18 insertions, 19 deletions
diff --git a/README.rst b/README.rst
index 803175a..269472c 100644
--- a/README.rst
+++ b/README.rst
@@ -44,14 +44,13 @@ Documentation can be found `here <http://readthedocs.org/docs/apscheduler/en/lat
Source
------
-The source can be browsed at `Bitbucket <http://bitbucket.org/agronholm/apscheduler/src/>`_.
+The source can be browsed at `Github <https://github.com/agronholm/apscheduler>`_.
Reporting bugs
--------------
-A `bug tracker <https://bitbucket.org/agronholm/apscheduler/issues?status-new&status-open>`_
-is provided by bitbucket.org.
+A `bug tracker <https://github.com/agronholm/apscheduler/issues>`_ is provided by Github.
Getting help
diff --git a/docs/contributing.rst b/docs/contributing.rst
index c983ab8..41cae5f 100644
--- a/docs/contributing.rst
+++ b/docs/contributing.rst
@@ -9,14 +9,14 @@ changes accepted. This is to maintain the high quality of the code base.
Contribution Process
====================
-1. Fork the project on BitBucket
+1. Fork the project on Github
2. Clone the fork to your local machine
3. Make the changes to the project
4. Run the test suite with tox (if you changed any code)
5. Repeat steps 3-4 until the test suite passes
6. Commit if you haven't already
-7. Push the changes to your BitBucket fork
-8. Make a pull request on BitBucket
+7. Push the changes to your Github fork
+8. Make a pull request on Github
There is no need to update the change log -- this will be done prior to the next release at the latest.
Should the test suite fail even before your changes (which should be rare), make sure you're at least not adding to the
diff --git a/docs/modules/jobstores/memory.rst b/docs/modules/jobstores/memory.rst
index 31913e3..c91935c 100644
--- a/docs/modules/jobstores/memory.rst
+++ b/docs/modules/jobstores/memory.rst
@@ -23,7 +23,7 @@ unreachable globally and use job non-serializable job arguments.
- none
* - Example
- ``examples/schedulers/blocking.py``
- (`view online <https://bitbucket.org/agronholm/apscheduler/src/master/examples/schedulers/blocking.py>`_).
+ (`view online <https://github.com/agronholm/apscheduler/tree/master/examples/schedulers/blocking.py>`_).
.. caution:: Unlike with other job stores, changes made to any mutable job arguments persist across job invocations.
You can use this to your advantage, however.
diff --git a/docs/modules/jobstores/mongodb.rst b/docs/modules/jobstores/mongodb.rst
index 4454dba..ffc1375 100644
--- a/docs/modules/jobstores/mongodb.rst
+++ b/docs/modules/jobstores/mongodb.rst
@@ -22,4 +22,4 @@ MongoDBJobStore stores jobs in a `MongoDB <http://www.mongodb.com/>`_ database.
- `pymongo <https://pypi.python.org/pypi/pymongo/>`_
* - Example
- ``examples/jobstores/mongodb.py``
- (`view online <https://bitbucket.org/agronholm/apscheduler/src/master/examples/jobstores/mongodb.py>`_).
+ (`view online <https://github.com/agronholm/apscheduler/tree/master/examples/jobstores/mongodb.py>`_).
diff --git a/docs/modules/jobstores/redis.rst b/docs/modules/jobstores/redis.rst
index 55284ee..e016c44 100644
--- a/docs/modules/jobstores/redis.rst
+++ b/docs/modules/jobstores/redis.rst
@@ -22,4 +22,4 @@ RedisJobStore stores jobs in a `redis <http://redis.io/>`_ database.
- `redis <https://pypi.python.org/pypi/redis/>`_
* - Example
- ``examples/jobstores/redis_.py``
- (`view online <https://bitbucket.org/agronholm/apscheduler/src/master/examples/jobstores/redis_.py>`_).
+ (`view online <https://github.com/agronholm/apscheduler/tree/master/examples/jobstores/redis_.py>`_).
diff --git a/docs/modules/jobstores/sqlalchemy.rst b/docs/modules/jobstores/sqlalchemy.rst
index 937bab3..bde80c1 100644
--- a/docs/modules/jobstores/sqlalchemy.rst
+++ b/docs/modules/jobstores/sqlalchemy.rst
@@ -25,4 +25,4 @@ connection URL.
- `SQLAlchemy <https://pypi.python.org/pypi/SQLAlchemy/>`_ (+ the backend specific driver package)
* - Example
- ``examples/jobstores/sqlalchemy_.py``
- (`view online <https://bitbucket.org/agronholm/apscheduler/src/master/examples/jobstores/sqlalchemy_.py>`_).
+ (`view online <https://github.com/agronholm/apscheduler/tree/master/examples/jobstores/sqlalchemy_.py>`_).
diff --git a/docs/modules/schedulers/asyncio.rst b/docs/modules/schedulers/asyncio.rst
index e22d786..db8a07d 100644
--- a/docs/modules/schedulers/asyncio.rst
+++ b/docs/modules/schedulers/asyncio.rst
@@ -29,4 +29,4 @@ If you have an application that runs on an AsyncIO event loop, you will want to
* Python <= 3.2: `trollius <https://pypi.python.org/pypi/trollius/>`_
* - Example
- ``examples/schedulers/asyncio_.py``
- (`view online <https://bitbucket.org/agronholm/apscheduler/src/master/examples/schedulers/asyncio_.py>`_).
+ (`view online <https://github.com/agronholm/apscheduler/tree/master/examples/schedulers/asyncio_.py>`_).
diff --git a/docs/modules/schedulers/background.rst b/docs/modules/schedulers/background.rst
index f9b0158..b12cd20 100644
--- a/docs/modules/schedulers/background.rst
+++ b/docs/modules/schedulers/background.rst
@@ -26,4 +26,4 @@ after the call returns.
- none
* - Example
- ``examples/schedulers/background.py``
- (`view online <https://bitbucket.org/agronholm/apscheduler/src/master/examples/schedulers/background.py>`_).
+ (`view online <https://github.com/agronholm/apscheduler/tree/master/examples/schedulers/background.py>`_).
diff --git a/docs/modules/schedulers/blocking.rst b/docs/modules/schedulers/blocking.rst
index 1cab028..d923471 100644
--- a/docs/modules/schedulers/blocking.rst
+++ b/docs/modules/schedulers/blocking.rst
@@ -27,4 +27,4 @@ BlockingScheduler can be useful if you want to use APScheduler as a standalone s
- none
* - Example
- ``examples/schedulers/blocking.py``
- (`view online <https://bitbucket.org/agronholm/apscheduler/src/master/examples/schedulers/blocking.py>`_).
+ (`view online <https://github.com/agronholm/apscheduler/tree/master/examples/schedulers/blocking.py>`_).
diff --git a/docs/modules/schedulers/gevent.rst b/docs/modules/schedulers/gevent.rst
index 2260ced..56f63a5 100644
--- a/docs/modules/schedulers/gevent.rst
+++ b/docs/modules/schedulers/gevent.rst
@@ -25,7 +25,7 @@ GeventScheduler uses gevent natively, so it doesn't require monkey patching. By
- `gevent <https://pypi.python.org/pypi/gevent/>`_
* - Example
- ``examples/schedulers/gevent_.py``
- (`view online <https://bitbucket.org/agronholm/apscheduler/src/master/examples/schedulers/gevent_.py>`_).
+ (`view online <https://github.com/agronholm/apscheduler/tree/master/examples/schedulers/gevent_.py>`_).
.. tip:: Until there is an official Python 3 compatible release of gevent, you can use an
`unofficial port <https://github.com/fantix/gevent>`_.
diff --git a/docs/modules/schedulers/qt.rst b/docs/modules/schedulers/qt.rst
index 7a667b3..68b788c 100644
--- a/docs/modules/schedulers/qt.rst
+++ b/docs/modules/schedulers/qt.rst
@@ -25,4 +25,4 @@ QtScheduler lets you integrate APScheduler with your `PySide <https://en.wikiped
- PySide or PyQt
* - Example
- ``examples/schedulers/qt.py``
- (`view online <https://bitbucket.org/agronholm/apscheduler/src/master/examples/schedulers/qt.py>`_).
+ (`view online <https://github.com/agronholm/apscheduler/tree/master/examples/schedulers/qt.py>`_).
diff --git a/docs/modules/schedulers/tornado.rst b/docs/modules/schedulers/tornado.rst
index 45186e1..90c5a54 100644
--- a/docs/modules/schedulers/tornado.rst
+++ b/docs/modules/schedulers/tornado.rst
@@ -24,4 +24,4 @@ TornadoScheduler was meant to be used in `Tornado <http://www.tornadoweb.org/en/
- `tornado <https://pypi.python.org/pypi/tornado/>`_
* - Example
- ``examples/schedulers/tornado_.py``
- (`view online <https://bitbucket.org/agronholm/apscheduler/src/master/examples/schedulers/tornado_.py>`_)
+ (`view online <https://github.com/agronholm/apscheduler/tree/master/examples/schedulers/tornado_.py>`_)
diff --git a/docs/modules/schedulers/twisted.rst b/docs/modules/schedulers/twisted.rst
index d254a2e..21c0b3c 100644
--- a/docs/modules/schedulers/twisted.rst
+++ b/docs/modules/schedulers/twisted.rst
@@ -25,4 +25,4 @@ By default it uses the reactor's thread pool to execute jobs.
- `twisted <https://pypi.python.org/pypi/Twisted/>`_
* - Example
- ``examples/schedulers/twisted_.py``
- (`view online <https://bitbucket.org/agronholm/apscheduler/src/master/examples/schedulers/twisted_.py>`_).
+ (`view online <https://github.com/agronholm/apscheduler/tree/master/examples/schedulers/twisted_.py>`_).
diff --git a/docs/userguide.rst b/docs/userguide.rst
index 76b63b2..706fdf4 100644
--- a/docs/userguide.rst
+++ b/docs/userguide.rst
@@ -24,7 +24,7 @@ Code examples
The source distribution contains the :file:`examples` directory where you can find many working examples for using
APScheduler in different ways. The examples can also be
-`browsed online <https://bitbucket.org/agronholm/apscheduler/src/master/examples/?at=master>`_.
+`browsed online <https://github.com/agronholm/apscheduler/tree/master/examples/?at=master>`_.
Basic concepts
diff --git a/setup.py b/setup.py
index 9ea7eec..2dd8262 100644
--- a/setup.py
+++ b/setup.py
@@ -34,7 +34,7 @@ setup(
long_description=readme,
author='Alex Gronholm',
author_email='apscheduler@nextday.fi',
- url='http://pypi.python.org/pypi/APScheduler/',
+ url='https://github.com/agronholm/apscheduler',
classifiers=[
'Development Status :: 5 - Production/Stable',
'Intended Audience :: Developers',