summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Grönholm <alex.gronholm@nextday.fi>2012-09-04 09:31:37 +0300
committerAlex Grönholm <alex.gronholm@nextday.fi>2012-09-04 09:31:37 +0300
commit422f79bcef224a0ba2da02a445fc76e5302b9056 (patch)
tree88411b942da4600ddb1adedabec062953ac96f77
parente1614de75f767482787512b7ea172138e6d5038d (diff)
downloadapscheduler-422f79bcef224a0ba2da02a445fc76e5302b9056.tar.gz
Dropped Python 2.4 support; test the PyMongo job store on Jython too
-rw-r--r--CHANGES.rst2
-rw-r--r--README.rst2
-rw-r--r--docs/index.rst2
-rw-r--r--setup.py2
-rw-r--r--tox.ini13
5 files changed, 7 insertions, 14 deletions
diff --git a/CHANGES.rst b/CHANGES.rst
index 3e30629..ae6715f 100644
--- a/CHANGES.rst
+++ b/CHANGES.rst
@@ -13,6 +13,8 @@ APScheduler, see the :doc:`migration section <migration>`.
* Switched to PyPy 1.9 for PyPy compatibility testing
+* Dropped Python 2.4 support
+
2.0.3
-----
diff --git a/README.rst b/README.rst
index 5dff7da..96b6525 100644
--- a/README.rst
+++ b/README.rst
@@ -17,7 +17,7 @@ Features
* No (hard) external dependencies
* Thread-safe API
-* Excellent test coverage (tested on CPython 2.4 - 2.7, 3.2 - 3.3, Jython 2.5.3, PyPy 1.9)
+* Excellent test coverage (tested on CPython 2.5 - 2.7, 3.2 - 3.3, Jython 2.5.3, PyPy 1.9)
* Configurable scheduling mechanisms (triggers):
* Cron-like scheduling
diff --git a/docs/index.rst b/docs/index.rst
index 488f5f1..2f6a07d 100644
--- a/docs/index.rst
+++ b/docs/index.rst
@@ -25,7 +25,7 @@ Features
* No (hard) external dependencies
* Thread-safe API
-* Excellent test coverage (tested on CPython 2.4 - 2.7, 3.2, Jython 2.5.3, PyPy 1.9)
+* Excellent test coverage (tested on CPython 2.5 - 2.7, 3.2, Jython 2.5.3, PyPy 1.9)
* Configurable scheduling mechanisms (triggers):
* Cron-like scheduling
diff --git a/setup.py b/setup.py
index 2cb3411..3287416 100644
--- a/setup.py
+++ b/setup.py
@@ -25,12 +25,10 @@ setup(
'Intended Audience :: Developers',
'License :: OSI Approved :: MIT License',
'Programming Language :: Python',
- 'Programming Language :: Python :: 2.4',
'Programming Language :: Python :: 2.5',
'Programming Language :: Python :: 2.6',
'Programming Language :: Python :: 2.7',
'Programming Language :: Python :: 3',
- 'Programming Language :: Python :: 3.1',
'Programming Language :: Python :: 3.2',
'Programming Language :: Python :: 3.3'
],
diff --git a/tox.ini b/tox.ini
index a4caa20..a5184c4 100644
--- a/tox.ini
+++ b/tox.ini
@@ -1,27 +1,20 @@
[tox]
-envlist = py24,py25,py26,py27,py32,py33,jython,pypy19
+envlist = py25,py26,py27,py32,py33,jython,pypy19
[testenv]
deps=nose
sqlalchemy
pymongo
- git+https://github.com/andymccurdy/redis-py.git
+ redis
commands=nosetests []
-[testenv:py24]
-deps=nose
- sqlalchemy
- pymongo
- pysqlite
-
[testenv:py33]
basepython=python3.3
# Jython does not have SQLite, so don't download SQLAlchemy.
-# Also, because of a Jython bug (http://bugs.jython.org/issue1701), the MongoDB
-# job store does not work correctly, so don't install Pymongo either.
[testenv:jython]
deps=nose
+ pymongo
redis
[testenv:pypy19]