summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorNed Batchelder <ned@nedbatchelder.com>2015-08-29 17:05:19 -0400
committerNed Batchelder <ned@nedbatchelder.com>2015-08-29 17:05:19 -0400
commitc09493c3ac0c45af24b44e976a01afcabc71ad47 (patch)
treea538f15ec868c194881a2d5732060208214a8606 /setup.py
parent798f8ade2e1ce83548ac066ecaac3a2e8ed3c657 (diff)
downloadpython-coveragepy-c09493c3ac0c45af24b44e976a01afcabc71ad47.tar.gz
Make this code look right
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py39
1 files changed, 20 insertions, 19 deletions
diff --git a/setup.py b/setup.py
index 08c1659..50315be 100644
--- a/setup.py
+++ b/setup.py
@@ -23,7 +23,8 @@ setup.cfg support, plugins for other file variants, supported data API,
# This file is used unchanged under all versions of Python, 2.x and 3.x.
# Pull in the tools we need.
-import os, sys
+import os
+import sys
from setuptools import setup
from distutils.core import Extension # pylint: disable=no-name-in-module, import-error
@@ -73,32 +74,32 @@ scripts = [
# Create the keyword arguments for setup()
setup_args = dict(
- name = 'coverage',
- version = __version__,
+ name='coverage',
+ version=__version__,
- packages = [
+ packages=[
'coverage',
],
- package_data = {
+ package_data={
'coverage': [
'htmlfiles/*.*',
]
},
- entry_points = {'console_scripts': scripts},
+ entry_points={'console_scripts': scripts},
# We need to get HTML assets from our htmlfiles directory.
- zip_safe = False,
-
- author = 'Ned Batchelder and others',
- author_email = 'ned@nedbatchelder.com',
- description = doclines[0],
- long_description = '\n'.join(doclines[2:]),
- keywords = 'code coverage testing',
- license = 'Apache 2.0',
- classifiers = classifier_list,
- url = __url__,
+ zip_safe=False,
+
+ author='Ned Batchelder and others',
+ author_email='ned@nedbatchelder.com',
+ description=doclines[0],
+ long_description='\n'.join(doclines[2:]),
+ keywords='code coverage testing',
+ license='Apache 2.0',
+ classifiers=classifier_list,
+ url=__url__,
)
# A replacement for the build_ext command which raises a single exception
@@ -161,7 +162,7 @@ if '__pypy__' in sys.builtin_module_names:
if compile_extension:
setup_args.update(dict(
- ext_modules = [
+ ext_modules=[
Extension(
"coverage.tracer",
sources=[
@@ -172,7 +173,7 @@ if compile_extension:
]
)
],
- cmdclass = {
+ cmdclass={
'build_ext': ve_build_ext,
},
))
@@ -181,7 +182,7 @@ if compile_extension:
if sys.version_info >= (3, 0):
setup_args.update(dict(
- use_2to3 = False,
+ use_2to3=False,
))