summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in13
1 files changed, 7 insertions, 6 deletions
diff --git a/configure.in b/configure.in
index 121908a7..ed88207c 100644
--- a/configure.in
+++ b/configure.in
@@ -1,7 +1,9 @@
-AC_INIT(gtk/gtkmodule.c)
+AC_INIT(pygtk, 0.7.1,
+ [http://bugzilla.gnome.org/enter_bug.cgi?product=gnome-python&component=pygtk])
+AC_CONFIG_SRCDIR([gtk/gtkmodule.c])
AM_CONFIG_HEADER(config.h)
-AM_INIT_AUTOMAKE(pygtk, 0.7.1)
+AM_INIT_AUTOMAKE(AC_PACKAGE_NAME, AC_PACKAGE_VERSION)
dnl put the ACLOCAL flags in the makefile
ACLOCAL="$ACLOCAL $ACLOCAL_FLAGS"
@@ -30,11 +32,9 @@ fi
AM_PATH_GLIB_2_0(1.3.7,,[AC_MSG_ERROR(maybe you want the gtk-gnome-1-2 branch?)],gobject)
PKG_CHECK_MODULES(PANGO, pango >= 0.17,,[AC_MSG_ERROR(maybe you want the gtk-gnome-1-2 branch?)])
-AM_PATH_GTK_2_0(1.3.7,,[AC_MSG_ERROR(maybe you want the gtk-gnome-1-2 branch?)],$extra_mods)
-
-dnl this is so that automake picks up the SUBSTs. autoconf already has them
AC_SUBST(PANGO_CFLAGS)
AC_SUBST(PANGO_LIBS)
+AM_PATH_GTK_2_0(1.3.7,,[AC_MSG_ERROR(maybe you want the gtk-gnome-1-2 branch?)],$extra_mods)
dnl AM_PATH_GDK_IMLIB(1.8, build_imlib=true, build_imlib=false)
dnl AM_CONDITIONAL(BUILD_IMLIB, $build_imlib)
@@ -67,6 +67,7 @@ if test "x$enable_numpy" != xno; then
CPPFLAGS="$save_CPPFLAGS"
fi
-AC_OUTPUT(Makefile codegen/Makefile gtk/Makefile codegen/pygtk-codegen-2.0)
+AC_CONFIG_FILES([Makefile codegen/Makefile gtk/Makefile codegen/pygtk-codegen-2.0])
+AC_OUTPUT