summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorJohan Dahlin <johan@src.gnome.org>2005-01-10 16:57:42 +0000
committerJohan Dahlin <johan@src.gnome.org>2005-01-10 16:57:42 +0000
commitde73df28b1d7c62133b2799dd6663f7b44444c64 (patch)
tree53054eb3ba220dd0bc9631a966adea4559a2bf70 /setup.py
parentd57cd700edb1e5aae421b66612aec9e9821f7f64 (diff)
downloadpygtk-de73df28b1d7c62133b2799dd6663f7b44444c64.tar.gz
Make the build of atk, pango and gtk conditional. Fixes bug #74144.
* .cvsignore: * Makefile.am: * configure.in: * gtk/Makefile.am: * pygtk-2.0.pc.in: * setup.py: * tests/common.py: * tests/testhelpermodule.c: Make the build of atk, pango and gtk conditional. Fixes bug #74144.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py2
1 files changed, 2 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 701a2ab6..06ba1613 100755
--- a/setup.py
+++ b/setup.py
@@ -77,6 +77,8 @@ class PyGtkInstallLib(InstallLib):
InstallLib.run(self)
+ self.install_template('pygobject-2.0.pc.in',
+ os.path.join(self.libdir, 'pkgconfig'))
def install_pth(self):
"""Write the pygtk.pth file"""
file = os.path.join(self.install_dir, 'pygtk.pth')