summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorCedric Gustin <cedric.gustin@swing.be>2005-02-23 08:00:22 +0000
committerCedric Gustin <gustin@src.gnome.org>2005-02-23 08:00:22 +0000
commitf27e2f06a91ec773d11937cf078777944d4f43d6 (patch)
tree2dc5acf2d5e91a85fce58fac19eea2b061d2e3ee /setup.py
parent11e3050a80150f5c4fdcb91d6a51015363f26f34 (diff)
downloadpygtk-f27e2f06a91ec773d11937cf078777944d4f43d6.tar.gz
Move the install_template call for pygobject-2.0.pc.in to the right place
2005-02-23 Cedric Gustin <cedric.gustin@swing.be> * setup.py: Move the install_template call for pygobject-2.0.pc.in to the right place in the script. Also define PLATFORM_WIN32 on win32. Fixes bug #150616. * codegen/codegen.py: Do not write the 'pygtk class init' function for objects whose type is explicitly ignored (like GtkPlug and GtkSocket on win32). Otherwise, it generates glib-warnings related to calls to g_object_set_qdata with a NULL 'node'. * gobject/pygtype.c: Do not use g_string_append_printf with a NULL argument, as it crashes on win32. Fixes bug #166546. * gtk/gtk.override: Add GtkSocket__proxy_do_plug_added, GtkSocket__proxy_do_plug_removed and GtkPlug__proxy_do_embedded to the ignore-win32 list.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py6
1 files changed, 4 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 06ba1613..f5f5c202 100755
--- a/setup.py
+++ b/setup.py
@@ -51,6 +51,7 @@ GLOBAL_MACROS += [('PYGTK_MAJOR_VERSION', MAJOR_VERSION),
if sys.platform == 'win32':
GLOBAL_MACROS.append(('VERSION', '\\\"%s\\\"' % VERSION))
+ GLOBAL_MACROS.append(('PLATFORM_WIN32',1))
else:
GLOBAL_MACROS.append(('VERSION', '"%s"' % VERSION))
@@ -77,8 +78,6 @@ class PyGtkInstallLib(InstallLib):
InstallLib.run(self)
- self.install_template('pygobject-2.0.pc.in',
- os.path.join(self.libdir, 'pkgconfig'))
def install_pth(self):
"""Write the pygtk.pth file"""
file = os.path.join(self.install_dir, 'pygtk.pth')
@@ -112,6 +111,9 @@ class PyGtkInstallData(InstallData):
self.install_template('pygtk-2.0.pc.in',
os.path.join(self.install_dir,
'lib','pkgconfig'))
+ self.install_template('pygobject-2.0.pc.in',
+ os.path.join(self.install_dir,
+ 'lib', 'pkgconfig'))
class PyGtkBuild(build):
enable_threading = 1