diff options
author | Johan Dahlin <johan@src.gnome.org> | 2004-08-02 11:03:05 +0000 |
---|---|---|
committer | Johan Dahlin <johan@src.gnome.org> | 2004-08-02 11:03:05 +0000 |
commit | 92e0b9e24a60f47c216cf625de22fa46e7df0296 (patch) | |
tree | 67fff2ad85c5926e1f1be38710ef1827b229495f /setup.py | |
parent | 3c5e6f41e151f4b8b8471b5b3a8de1c64ad36588 (diff) | |
download | pygtk-92e0b9e24a60f47c216cf625de22fa46e7df0296.tar.gz |
Call PyEval_InitThreads. Perhaps its something that always should be
* gobject/gobjectmodule.c (initgobject): Call
PyEval_InitThreads. Perhaps its something that always should be
called.
* README (Author): Add a requirements section
* configure.in: Require Python 2.3
* setup.py (version): Ditto
* gobject/pygtype.c, gobject/pygobject.h: Remove 2.2 compat.
* All over the place: Add support for PyGILState.
Diffstat (limited to 'setup.py')
-rwxr-xr-x | setup.py | 10 |
1 files changed, 5 insertions, 5 deletions
@@ -32,11 +32,11 @@ VERSION = "%d.%d.%d" % (MAJOR_VERSION, MINOR_VERSION, MICRO_VERSION) -GOBJECT_REQUIRED = '2.2.0' +GOBJECT_REQUIRED = '2.4.0' ATK_REQUIRED = '1.0.0' PANGO_REQUIRED = '1.0.0' -GTK_REQUIRED = '2.2.0' -LIBGLADE_REQUIRED = '2.0.0' +GTK_REQUIRED = '2.4.0' +LIBGLADE_REQUIRED = '2.3.6' PYGTK_SUFFIX = '2.0' PYGTK_SUFFIX_LONG = 'gtk-' + PYGTK_SUFFIX @@ -57,9 +57,9 @@ INCLUDE_DIR = os.path.join('include', 'pygtk-%s' % PYGTK_SUFFIX) str_version = sys.version[:3] version = map(int, str_version.split('.')) -if version < [2, 2]: +if version < [2, 3]: raise SystemExit, \ - "Python 2.2 or higher is required, %s found" % str_version + "Python 2.3 or higher is required, %s found" % str_version class PyGtkInstallLib(InstallLib): def run(self): |