summaryrefslogtreecommitdiff
path: root/gtk/Makefile.am
diff options
context:
space:
mode:
authorJames Henstridge <james@daa.com.au>2000-11-29 00:46:05 +0000
committerJames Henstridge <jamesh@src.gnome.org>2000-11-29 00:46:05 +0000
commit1080e4e22532f3958083aa2d291631d571359739 (patch)
tree7b4f2e5b6f046a34a997d7bdf4039b00834bf436 /gtk/Makefile.am
parentffcc526ecfc03de11287b242ed4db0f792967b47 (diff)
downloadpygtk-1080e4e22532f3958083aa2d291631d571359739.tar.gz
fix bug where mod.__file__ is the .pyc file rather than the .py file.
2000-11-29 James Henstridge <james@daa.com.au> * examples/testgtk/testgtk.py (load_module): fix bug where mod.__file__ is the .pyc file rather than the .py file. * gtk/gtk.defs: change parent type for some classes to GtkDialog to match changes in gtk+. * gtk/Makefile.am (pysitedir, pyexecdir): fix up directory names. It wasn't installing these files in a gtk/ subdirectory :(
Diffstat (limited to 'gtk/Makefile.am')
-rw-r--r--gtk/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/gtk/Makefile.am b/gtk/Makefile.am
index 70051ed5..52a9a27b 100644
--- a/gtk/Makefile.am
+++ b/gtk/Makefile.am
@@ -12,10 +12,10 @@ INCLUDES = -I$(top_srcdir) $(PYTHON_INCLUDES) $(GTK_CFLAGS) \
#glmodule = glmodule.la
#endif
-pysitedir = $(PYTHON_SITE)
+pysitedir = $(PYTHON_SITE)/gtk
pysite_PYTHON = __init__.py GTK.py GDK.py
-pyexecdir = $(PYTHON_SITE_EXEC)
+pyexecdir = $(PYTHON_SITE_EXEC)/gtk
pyexec_LTLIBRARIES = _gtkmodule.la #$(imlibmodule) $(libglademodule) $(glmodule)
_gtkmodule_la_LDFLAGS = -module -avoid-version