summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorJames Henstridge <jamesh@src.gnome.org>2002-01-22 08:53:16 +0000
committerJames Henstridge <jamesh@src.gnome.org>2002-01-22 08:53:16 +0000
commitda61c52e46adb478cb653369460eb5baf818c4a8 (patch)
treebca5167502219974a5afc2d5f7fe38bd9bf8771a /configure.in
parent0ceb083a1d39cc2adbf7a5d229ac66c1e3fcd260 (diff)
downloadpygtk-da61c52e46adb478cb653369460eb5baf818c4a8.tar.gz
add warnings to CFLAGS
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in15
1 files changed, 15 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 415881d2..468ec53e 100644
--- a/configure.in
+++ b/configure.in
@@ -116,6 +116,21 @@ if test "x$enable_numpy" != xno; then
CPPFLAGS="$save_CPPFLAGS"
fi
+dnl add debugging options ...
+changequote(,)dnl
+if test "x$GCC" = xyes; then
+ case " $CFLAGS " in
+ *[\ \ ]-Wall[\ \ ]*) ;;
+ *) CFLAGS="$CFLAGS -Wall" ;;
+ esac
+
+ case " $CFLAGS " in
+ *[\ \ ]-ansi[\ \ ]*) ;;
+ *) CFLAGS="$CFLAGS -ansi" ;;
+ esac
+fi
+changequote([,])dnl
+
AC_CONFIG_FILES(
Makefile
pygtk-2.0.pc