summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorJohan Dahlin <johan@src.gnome.org>2004-08-03 18:38:14 +0000
committerJohan Dahlin <johan@src.gnome.org>2004-08-03 18:38:14 +0000
commit50b30e37d85c262ba1e78e434bbce99c928ce0ca (patch)
tree72980cef22c9e64db5888c8f55a39483421b7ddc /configure.in
parent8cd34d3c6a74e51e6900cc386b2fc2e53f8f6ac9 (diff)
downloadpygtk-50b30e37d85c262ba1e78e434bbce99c928ce0ca.tar.gz
Urgh. more threading 'fixes'
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 6ace2bc9..b4a89e52 100644
--- a/configure.in
+++ b/configure.in
@@ -73,12 +73,15 @@ AM_CHECK_PYMOD(thread,,,enable_thread=no)
AC_MSG_CHECKING(whether to enable threading in pygtk)
if test "x$enable_thread" != xno; then
extra_mods=gthread
- AC_DEFINE(ENABLE_PYGTK_THREADING,,[enable threading support in pygtk])
+ THREADING_CFLAGS=
AC_MSG_RESULT(yes)
else
extra_mods=
+ THREADING_CFLAGS="-DDISABLE_THREADING"
AC_MSG_RESULT(no)
fi
+AC_SUBST(THREADING_CFLAGS)
+CPPFLAGS="${CPPFLAGS} $THREADING_CFLAGS"
dnl get rid of the -export-dynamic stuff from the configure flags ...
export_dynamic=`(./libtool --config; echo eval echo \\$export_dynamic_flag_spec) | sh`