summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorJames Henstridge <james@daa.com.au>2001-03-13 05:41:00 +0000
committerJames Henstridge <jamesh@src.gnome.org>2001-03-13 05:41:00 +0000
commita97b10d7e4df7f18b12f5654ac2ad4d1cc090c56 (patch)
tree4a40891ac948e1ef7aa8e1f56fc32a25f8db7e32 /configure.in
parent7257836a22fae4da4a0c0f48472168238a25463b (diff)
downloadpygtk-a97b10d7e4df7f18b12f5654ac2ad4d1cc090c56.tar.gz
add configure checks for the pixbuf library.
2001-03-13 James Henstridge <james@daa.com.au> * configure.in (BUILD_PIXBUF): add configure checks for the pixbuf library. * gdkpixbufmodule.c, pygdkpixbuf.h: start of a GdkPixbuf module. Only covers the basics the GdkPixbuf type right now -- no animations or progressive loading. * gtk.py (GtkNotebook.set_tab_vborder): call the correct function here. * gtkmodule.c (_wrap_gtk_clist_get_pixmap): fix format string for reading args here.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 3ace4932..8990ad92 100644
--- a/configure.in
+++ b/configure.in
@@ -27,6 +27,9 @@ AM_PATH_GTK(1.2.6,,,$extra_mods)
AM_PATH_GDK_IMLIB(1.8, build_imlib=true, build_imlib=false)
AM_CONDITIONAL(BUILD_IMLIB, $build_imlib)
+AM_PATH_GDK_PIXBUF(0.9.0, build_pixbuf=true, build_pixbuf=false)
+AM_CONDITIONAL(BUILD_PIXBUF, $build_pixbuf)
+
AM_PATH_GTKGL(build_gtkgl=true, build_gtkgl=false)
AM_CONDITIONAL(BUILD_GTKGL, $build_gtkgl)