summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index fb692373..d4fcbe35 100644
--- a/configure.ac
+++ b/configure.ac
@@ -124,6 +124,16 @@ AC_ARG_ENABLE(thread,
AC_HELP_STRING([--disable-thread], [Disable pygobject threading support]),,
enable_thread=yes)
+dnl Build with the new caching invoker
+AC_ARG_ENABLE(invoke-ng,
+ AC_HELP_STRING([--disable-invoke-ng], [Disable the new caching invoke path]),,
+ enable_invoke_ng=yes)
+if test "${enable_invoke_ng}" == yes; then
+ AC_DEFINE(ENABLE_INVOKE_NG, 1, Enable the new invoke caching code path)
+fi
+
+AM_CONDITIONAL(ENABLE_INVOKE_NG, test x$enable_invoke_ng == xyes)
+
dnl Building documentation
AC_ARG_ENABLE(docs,
AC_HELP_STRING([--enable-docs], [Enable documentation building]),enable_docs=$enableval,
@@ -284,4 +294,5 @@ AC_OUTPUT
echo
echo "libffi support: $have_libffi"
echo "introspection support: $enable_introspection"
+echo "invoke-ng support: $enable_invoke_ng"
echo