summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 4d1fdda7..c3ba1a80 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -87,6 +87,13 @@ endif
# python
pyexec_LTLIBRARIES =
+EGG_NAME = $(PACKAGE)-$(PACKAGE_VERSION)-py$(PYTHON_VERSION)
+install-data-local:
+ $(mkinstalldirs) $(DESTDIR)$(pyexecdir)
+ cp $(top_builddir)/PKG-INFO $(DESTDIR)$(pyexecdir)/$(EGG_NAME).egg-info
+uninstall-local:
+ rm -f $(DESTDIR)$(pyexecdir)/$(EGG_NAME).egg-info
+
release-news:
printf "%-8s%s\n" "$(VERSION)" "`LC_TIME=C date '+%d-%b-%Y'`" > NEWS.tmp