summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorCedric Gustin <cedric.gustin@gmail.com>2006-06-28 09:01:19 +0000
committerCedric Gustin <gustin@src.gnome.org>2006-06-28 09:01:19 +0000
commitfc8007f765f81ca864fb8de72abc5a7b49357ec2 (patch)
treed6eaf64566eeb29068ba1e0f075785091cc9d070 /setup.py
parentbbe3b88b3a15a15b5d015d9ef1911b1181032141 (diff)
downloadpygobject-fc8007f765f81ca864fb8de72abc5a7b49357ec2.tar.gz
Set datarootdir in .pc file.
2006-06-28 Cedric Gustin <cedric.gustin@gmail.com> * dsextras.py (InstallData): Set datarootdir in .pc file. * pygobject_postinstall.py (replace_prefix): Do not parse pygtk-codegen-2.0 as it is part of pygtk. * setup.py: Create gobject extension as gobject._gobject. Add pygoptioncontext.c and pygoptiongroup.c to the list of source files. Add option.py to the module files. Changed name of distutils package from pygtk to pygobject.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py7
1 files changed, 5 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 2aaaadfd..3cced9fd 100755
--- a/setup.py
+++ b/setup.py
@@ -105,7 +105,7 @@ PyGObjectBuild.user_options.append(('enable-threading', None,
'enable threading support'))
# GObject
-gobject = PkgConfigExtension(name='_gobject', pkc_name='gobject-2.0',
+gobject = PkgConfigExtension(name='gobject._gobject', pkc_name='gobject-2.0',
pkc_version=GOBJECT_REQUIRED,
pygobject_pkc=None,
sources=['gobject/gobjectmodule.c',
@@ -115,6 +115,8 @@ gobject = PkgConfigExtension(name='_gobject', pkc_name='gobject-2.0',
'gobject/pygobject.c',
'gobject/pygmaincontext.c',
'gobject/pygmainloop.c',
+ 'gobject/pygoptioncontext.c',
+ 'gobject/pygoptiongroup.c',
'gobject/pygparamspec.c',
'gobject/pygpointer.c',
'gobject/pygtype.c',
@@ -126,6 +128,7 @@ data_files = []
ext_modules = []
py_modules = []
py_modules.append('dsextras')
+py_modules.append('gobject.option')
if not have_pkgconfig():
print "Error, could not find pkg-config"
@@ -177,7 +180,7 @@ doclines = __doc__.split("\n")
options = {"bdist_wininst": {"install_script": "pygobject_postinstall.py"}}
-setup(name="pygtk",
+setup(name="pygobject",
url='http://www.pygtk.org/',
version=VERSION,
license='LGPL',