summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorChristoph Reiter <reiter.christoph@gmail.com>2018-02-14 01:16:51 +0100
committerChristoph Reiter <reiter.christoph@gmail.com>2018-02-14 01:28:16 +0100
commit0d3fbc2a8d10c9eea4e3eef905d52c946f8ab7e9 (patch)
tree85540b2dca094e7b3d467c3bdb500a25553ae52e /setup.py
parent0fcd57846b0053319dc5a28503d3eab173927fc6 (diff)
downloadpygobject-0d3fbc2a8d10c9eea4e3eef905d52c946f8ab7e9.tar.gz
setup.py: set the same env vars for testing as autotools
Also don't print a Python stack trace of the calling process on error, just return the error status.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py8
1 files changed, 6 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 8bddefc3..ac65294e 100755
--- a/setup.py
+++ b/setup.py
@@ -452,11 +452,15 @@ class test(Command):
env = os.environ.copy()
env.pop("MSYSTEM", None)
+ env["MALLOC_PERTURB_"] = "85"
+ env["MALLOC_CHECK_"] = "3"
+ env["G_SLICE"] = "debug-blocks"
+
tests_dir = os.path.join(get_script_dir(), "tests")
- subprocess.check_call([
+ sys.exit(subprocess.call([
sys.executable,
os.path.join(tests_dir, "runtests.py"),
- ], env=env)
+ ], env=env))
class quality(Command):