summaryrefslogtreecommitdiff
path: root/pygtkcompat/Makefile.am
diff options
context:
space:
mode:
authorSimon Feltman <s.feltman@gmail.com>2012-08-29 03:46:23 -0700
committerSimon Feltman <sfeltman@src.gnome.org>2013-02-18 02:54:38 -0800
commita10fb7216de57046d1ecacb73dd032eaadcbad09 (patch)
tree8c347fdb4d32a34d3732a2dc1f0dfbbd0a3a41d2 /pygtkcompat/Makefile.am
parent871878c7a1e18fbdbf0744e0dd52cbcc6b610cdb (diff)
downloadpygobject-a10fb7216de57046d1ecacb73dd032eaadcbad09.tar.gz
pygtkcompat: Add pygtk compatible GenericTreeModel implementation
Add Python implementation of the GenericTreeModel that was available in pygtk. The implementation attempts a better job than the original at ref counting by guaranteeing no leaks upon deletion of the model itself. Or by using the extra "node" argument to the row_deleted signal. The model is available in the pygtkcompat package directly as pygtkcompat.generictreemodel.GenericTreeModel or with as gtk.GenericTreeModel when pygtkcompat.enable_gtk() is set. Add file list and tree demos making use of GenericTreeModel to gtk-demo. Auto-expand gtk-demo app tree to give a better overview of the demos available. https://bugzilla.gnome.org/show_bug.cgi?id=682933
Diffstat (limited to 'pygtkcompat/Makefile.am')
-rw-r--r--pygtkcompat/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/pygtkcompat/Makefile.am b/pygtkcompat/Makefile.am
index 6a73cb4c..914b3e25 100644
--- a/pygtkcompat/Makefile.am
+++ b/pygtkcompat/Makefile.am
@@ -2,6 +2,7 @@ pygtkcompatdir = $(pyexecdir)/pygtkcompat
pygtkcompat_PYTHON = \
__init__.py \
+ generictreemodel.py \
pygtkcompat.py
# if we build in a separate tree, we need to symlink the *.py files from the