summaryrefslogtreecommitdiff
path: root/gobject/Makefile.am
diff options
context:
space:
mode:
authorJohan Dahlin <johan@src.gnome.org>2006-04-11 15:14:36 +0000
committerJohan Dahlin <johan@src.gnome.org>2006-04-11 15:14:36 +0000
commitc10ecb8121f62361f744fd3d6034c9339890f6f8 (patch)
tree77cae05805368e46a7a4b34dff8df104c4d630cb /gobject/Makefile.am
parentdd6f0893eaea89726576fc960257334d00d4544e (diff)
downloadpygobject-c10ecb8121f62361f744fd3d6034c9339890f6f8.tar.gz
Turn gobject into a package; move _gobject to gobject._gobject and
add gobject/__init__.py. Update macros and testsuite.
Diffstat (limited to 'gobject/Makefile.am')
-rw-r--r--gobject/Makefile.am16
1 files changed, 10 insertions, 6 deletions
diff --git a/gobject/Makefile.am b/gobject/Makefile.am
index 2416fd59..d8e17c3b 100644
--- a/gobject/Makefile.am
+++ b/gobject/Makefile.am
@@ -6,17 +6,21 @@ pkgincludedir = $(includedir)/pygtk-$(PLATFORM_VERSION)
pkginclude_HEADERS = pygobject.h
pkgpyexecdir = $(pyexecdir)/gtk-2.0
-pkgpyexec_LTLIBRARIES = gobject.la
+pkgpyexec_LTLIBRARIES = _gobject.la
common_ldflags = -module -avoid-version
if PLATFORM_WIN32
common_ldflags += -no-undefined
endif
-gobject_la_CFLAGS = $(GLIB_CFLAGS)
-gobject_la_LDFLAGS = $(common_ldflags) -export-symbols-regex initgobject
-gobject_la_LIBADD = $(GLIB_LIBS)
-gobject_la_SOURCES = \
+# gobject python scripts
+pygobjectdir = $(pkgpythondir)/gtk
+pygobject_PYTHON = __init__.py
+
+_gobject_la_CFLAGS = $(GLIB_CFLAGS)
+_gobject_la_LDFLAGS = $(common_ldflags) -export-symbols-regex init_gobject
+_gobject_la_LIBADD = $(GLIB_LIBS)
+_gobject_la_SOURCES = \
gobjectmodule.c \
pygboxed.c \
pygenum.c \
@@ -33,5 +37,5 @@ gobject_la_SOURCES = \
pygtype.c
if PLATFORM_WIN32
-gobject_la_CFLAGS += -DPLATFORM_WIN32
+_gobject_la_CFLAGS += -DPLATFORM_WIN32
endif