summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJohn (J5) Palmieri <johnp@redhat.com>2011-05-31 16:59:41 -0400
committerJohn (J5) Palmieri <johnp@redhat.com>2011-05-31 16:59:41 -0400
commit4c9bcedb4e11ad66a4b86174e2425c7afcafc473 (patch)
treeafe86cfd7427398929f03eba450acc3575b6914d /configure.ac
parent2e4cfb85a55ff205e263591d573ee5ecf0ffff3e (diff)
downloadpygobject-4c9bcedb4e11ad66a4b86174e2425c7afcafc473.tar.gz
[gi-invoke-ng] enable invoke-ng by default
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index ad35f964..d4fcbe35 100644
--- a/configure.ac
+++ b/configure.ac
@@ -126,13 +126,13 @@ AC_ARG_ENABLE(thread,
dnl Build with the new caching invoker
AC_ARG_ENABLE(invoke-ng,
- AC_HELP_STRING([--enable-invoke-ng], [Enable the new caching invoke path]),,
- enable_invoke_ng=no)
-if test "${enable_invoke_ng}" != no; then
+ AC_HELP_STRING([--disable-invoke-ng], [Disable the new caching invoke path]),,
+ enable_invoke_ng=yes)
+if test "${enable_invoke_ng}" == yes; then
AC_DEFINE(ENABLE_INVOKE_NG, 1, Enable the new invoke caching code path)
fi
-AM_CONDITIONAL(ENABLE_INVOKE_NG, test x$enable_invoke_ng != xno)
+AM_CONDITIONAL(ENABLE_INVOKE_NG, test x$enable_invoke_ng == xyes)
dnl Building documentation
AC_ARG_ENABLE(docs,