summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJonathan Ballet <jon@multani.info>2013-02-14 07:50:02 +0100
committerMartin Pitt <martinpitt@gnome.org>2013-02-14 07:50:02 +0100
commitf6d4d2da676ae63d7a24dd172775b488ce665fe4 (patch)
tree0c11f70417f25b4478c969da5c15ee8f0b0931c6 /configure.ac
parent42cbff60e2032f715d9be6ab280954211899e03c (diff)
downloadpygobject-f6d4d2da676ae63d7a24dd172775b488ce665fe4.tar.gz
configure.ac: only enable code coverage when available
When building with an older gnome-common which does not yet provide code coverage support, disable it instead of breaking the configure script. https://bugzilla.gnome.org/show_bug.cgi?id=693328
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 9 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 9b7a72e0..c73d093f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -228,7 +228,15 @@ AC_SUBST(INTROSPECTION_COMPILER)
# compiler warnings, errors, required cflags, and code coverage support
GNOME_COMPILE_WARNINGS([maximum])
-GNOME_CODE_COVERAGE
+AC_MSG_CHECKING(for Gnome code coverage support)
+m4_ifdef([GNOME_CODE_COVERAGE],
+ [AC_MSG_RESULT(yes)
+ GNOME_CODE_COVERAGE],
+ [AC_MSG_RESULT(no)
+ GNOME_CODE_COVERAGE_RULES=''
+ AC_SUBST([GNOME_CODE_COVERAGE_RULES])
+ enable_code_coverage="no"])
+
if test "x$GCC" = "xyes"; then
JH_ADD_CFLAG([-Wall])
JH_ADD_CFLAG([-Werror=unused-variable])