summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorSimon Feltman <sfeltman@src.gnome.org>2013-10-31 03:13:53 -0700
committerSimon Feltman <sfeltman@src.gnome.org>2014-01-14 10:19:32 -0800
commit2624bd2b4a465a2d234951dd5b855fe8a0d46e1c (patch)
tree2f902f1a5514ab07f8c147d544904265d397d0d6 /Makefile.am
parentd3e8946dbb23197a2e9d7de351a7b9cd04d360b9 (diff)
downloadpygobject-2624bd2b4a465a2d234951dd5b855fe8a0d46e1c.tar.gz
Move gobject sub-module Python files into the main gi package
This moves the signalhelper, propertyhelper, and constants Python modules from gi/_gobject into gi. Keep gi/_gobject/__init__.py around because it is still needed to maintain the "_PyGObject_API" exposed by pygobject.h. This allows external modules compiled with prior versions of PyGObject to continue working with newer versions. https://bugzilla.gnome.org/show_bug.cgi?id=712197
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index ffcdc6a4..1c74126b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -58,7 +58,10 @@ nobase_pyexec_PYTHON = \
gi/module.py \
gi/importer.py \
gi/pygtkcompat.py \
- gi/docstring.py
+ gi/docstring.py \
+ gi/_constants.py \
+ gi/_propertyhelper.py \
+ gi/_signalhelper.py
# if we build in a separate tree, we need to symlink the *.py files from the
# source tree; Python does not accept the extensions and modules in different