summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorMartin Pitt <martin.pitt@ubuntu.com>2012-03-26 17:45:08 +0200
committerMartin Pitt <martin.pitt@ubuntu.com>2012-03-26 17:45:08 +0200
commit81de788a72b40acd2f857718d78bdeea01d12eb1 (patch)
tree93f196cc5e6271f19c7556a8fd7833abb251f235 /Makefile.am
parentf83d95e6fff572bda659a48e309b4524dafa4e83 (diff)
downloadpygobject-81de788a72b40acd2f857718d78bdeea01d12eb1.tar.gz
Fix "distcheck" and tests with out-of-tree builds
- Symlink *.py files from srcdir into builddir during build, as Python does not accept the extensions and modules in different paths. - "make clean" should remove *.pyc files - tests/runtests.py: Look for tests in srcdir, not in builddir
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 17cfc719..40077682 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -5,7 +5,9 @@ SUBDIRS = examples gi tests
PLATFORM_VERSION = 3.0
-CLEANFILES =
+CLEANFILES = \
+ `find "$(builddir)" -type f -name "*.pyc" -print`
+
EXTRA_DIST = \
ChangeLog.pre-2.18 \
pygobject-$(PLATFORM_VERSION).pc.in \
@@ -40,7 +42,7 @@ MAINTAINERCLEANFILES = \
$(srcdir)/m4/ltversion.m4 \
$(srcdir)/m4/lt~obsolete.m4 \
`find "$(srcdir)" -type f -name Makefile.in -print` \
- `find "$(srcdir)" -type f -name "*.pyc" -print`
+ `find "$(builddir)" -type f -name "*.pyc" -print`
BUILT_EXTRA_DIST = \
ChangeLog