summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTanu Kaskinen <tanu.kaskinen@linux.intel.com>2015-01-05 15:44:15 +0200
committerTanu Kaskinen <tanu.kaskinen@linux.intel.com>2015-01-05 16:14:19 +0200
commitce950b150d55159ef052a378ef3c99fe1e9665c7 (patch)
tree55856f082b392c57ea4c73865082decdc3fa9faf /configure.ac
parente0e0ebb03f949eef446305a2966b288382a27398 (diff)
downloadpulseaudio-ce950b150d55159ef052a378ef3c99fe1e9665c7.tar.gz
build-sys: Don't enable libsamplerate by default
The libsamplerate based resamplers have been deprecated, so it's best to not build them by default.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 68437297f..2ccf09407 100644
--- a/configure.ac
+++ b/configure.ac
@@ -673,9 +673,9 @@ fi
#### Libsamplerate support (optional) ####
AC_ARG_ENABLE([samplerate],
- AS_HELP_STRING([--disable-samplerate],[Disable optional libsamplerate support]))
+ AS_HELP_STRING([--enable-samplerate],[Enable optional libsamplerate support (DEPRECATED)]))
-AS_IF([test "x$enable_samplerate" != "xno"],
+AS_IF([test "x$enable_samplerate" = "xyes"],
[PKG_CHECK_MODULES(LIBSAMPLERATE, [ samplerate >= 0.1.0 ], HAVE_LIBSAMPLERATE=1, HAVE_LIBSAMPLERATE=0)],
HAVE_LIBSAMPLERATE=0)