summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTanu Kaskinen <tanu.kaskinen@linux.intel.com>2014-08-12 12:41:55 +0300
committerTanu Kaskinen <tanu.kaskinen@linux.intel.com>2014-08-17 08:24:47 +0300
commitbe8171be791da35d33de3d7d18c29137a85fe7e3 (patch)
tree10e7e6d11664dba9f8a0fec45da959fc9f446f15 /configure.ac
parentf480fb38a7ca0da07801e90f907fb98228261bf6 (diff)
downloadpulseaudio-be8171be791da35d33de3d7d18c29137a85fe7e3.tar.gz
shell-completion: Install the Zsh completions
This makes the Zsh completions work out-of-the-box. I also moved pulseaudio-zsh-completion.zsh to zsh/_pulseaudio to be in line with the common naming convention of Zsh completion files.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 837e81e63..dc2298dfe 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1353,6 +1353,13 @@ AC_ARG_WITH(
AC_SUBST(udevrulesdir)
+AC_ARG_WITH(
+ [zsh-completion-dir],
+ AS_HELP_STRING([--with-zsh-completion-dir], [Zsh completions directory (defaults to ${datadir}/zsh/site-functions)]),
+ [zshcompletiondir=$withval], [zshcompletiondir="${datadir}/zsh/site-functions"])
+
+AC_SUBST(zshcompletiondir)
+
AC_ARG_ENABLE([force-preopen],
AS_HELP_STRING([--enable-force-preopen],[Preopen modules, even when dlopen() is supported.]))
@@ -1465,6 +1472,7 @@ echo "
System Runtime Path: ${PA_SYSTEM_RUNTIME_PATH}
System State Path: ${PA_SYSTEM_STATE_PATH}
System Config Path: ${PA_SYSTEM_CONFIG_PATH}
+ Zsh completions directory: ${zshcompletiondir}
Compiler: ${CC}
CFLAGS: ${CFLAGS}
CPPFLAGS: ${CPPFLAGS}