summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorKamil Rytarowski <n54@gmx.com>2015-12-08 04:22:42 +0100
committerArun Raghavan <git@arunraghavan.net>2015-12-08 08:56:47 +0530
commit7f4acbd1c045ab3c6ae09ba221d2ba8c5bf880e9 (patch)
tree2659526780d91613971a899a1e637ef9ee8c51af /configure.ac
parent93cccdee8d80905f3df79822c1682baf5d3c4c95 (diff)
downloadpulseaudio-7f4acbd1c045ab3c6ae09ba221d2ba8c5bf880e9.tar.gz
netbsd: Revamp NetBSD platform checks
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 7 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 86b28d397..b9cd3d1a9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -137,6 +137,9 @@ case "$host_os" in
AC_MSG_RESULT([freebsd])
host_has_caps=1
;;
+ netbsd*)
+ AC_MSG_RESULT([netbsd])
+ ;;
darwin*)
AC_MSG_RESULT([darwin])
os_is_darwin=1
@@ -257,6 +260,10 @@ else
# HW specific atomic ops stuff
AC_MSG_CHECKING([architecture for native atomic operations])
case $host in
+ *-netbsd*)
+ AC_MSG_RESULT([yes])
+ need_libatomic_ops=no
+ ;;
arm*)
AC_MSG_RESULT([arm])
AC_MSG_CHECKING([whether we can use Linux kernel helpers])
@@ -292,10 +299,6 @@ else
])
fi
;;
- *-netbsdelf5*)
- AC_MSG_RESULT([yes])
- need_libatomic_ops=no
- ;;
*-freebsd*)
AC_MSG_RESULT([yes])
need_libatomic_ops=no