summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index 15cd2dc962..10a87348b4 100644
--- a/configure.in
+++ b/configure.in
@@ -1,5 +1,5 @@
dnl Process this file with autoconf to produce a configure script.
-dnl $PostgreSQL: pgsql/configure.in,v 1.525 2007/09/11 19:50:25 tgl Exp $
+dnl $PostgreSQL: pgsql/configure.in,v 1.526 2007/09/12 14:28:55 tgl Exp $
dnl
dnl Developers, please strive to achieve this order:
dnl
@@ -291,8 +291,8 @@ elif test "$ICC" = yes; then
# Intel's compiler has a bug/misoptimization in checking for
# division by NAN (NaN == 0), -mp1 fixes it, so add it to the CFLAGS.
PGAC_PROG_CC_CFLAGS_OPT([-mp1])
- # ICC prefers to spell the no-strict-aliasing switch like this
- PGAC_PROG_CC_CFLAGS_OPT([-fno-alias])
+ # Make sure strict aliasing is off (though this is said to be the default)
+ PGAC_PROG_CC_CFLAGS_OPT([-fno-strict-aliasing])
elif test x"${CC}" = x"xlc"; then
# AIX xlc has to have strict aliasing turned off too
PGAC_PROG_CC_CFLAGS_OPT([-qnoansialias])