summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in13
1 files changed, 13 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index f82e15c7e4..a40695b174 100644
--- a/configure.in
+++ b/configure.in
@@ -979,6 +979,19 @@ if test x"$HAVE_LONG_INT_64" = x"no" ; then
fi
+dnl If we need to use "long long int", figure out whether nnnLL notation works.
+
+if [[ x"$HAVE_LONG_LONG_INT_64" = xyes ]] ; then
+ AC_TRY_COMPILE([
+#define INT64CONST(x) x##LL
+long long int foo = INT64CONST(0x1234567890123456);
+],
+ [],
+ [AC_DEFINE(HAVE_LL_CONSTANTS)],
+ [])
+fi
+
+
dnl If we found "long int" is 64 bits, assume snprintf handles it.
dnl If we found we need to use "long long int", better check.
dnl We cope with snprintfs that use either %lld or %qd as the format.