summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorTom Lane <tgl@sss.pgh.pa.us>2017-11-09 11:00:36 -0500
committerTom Lane <tgl@sss.pgh.pa.us>2017-11-09 11:00:36 -0500
commit9aa6a1b29b0238802583a3b358142752a77c253d (patch)
tree1d808f008d36604c769618bab0e36824045df2f4 /configure.in
parentf57b070943e839a08a3676ae0b09b27dcbdec8a9 (diff)
downloadpostgresql-9aa6a1b29b0238802583a3b358142752a77c253d.tar.gz
Revert "Allow --with-bonjour to work with non-macOS implementations of Bonjour."
Upon further review, our Bonjour code doesn't actually work with the Avahi not-too-compatible compatibility library. While you can get it to work on non-macOS platforms if you link to Apple's own mDNSResponder code, there don't seem to be many people who care about that. Leaving in the AC_SEARCH_LIBS call seems more likely to encourage people to build broken configurations than to do anything very useful. Hence, remove the AC_SEARCH_LIBS call and put in a warning comment instead. Discussion: https://postgr.es/m/2D8331C5-D64F-44C1-8717-63EDC6EAF7EB@brightforge.com
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in8
1 files changed, 6 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index e33235cafc..c6e77b4ced 100644
--- a/configure.in
+++ b/configure.in
@@ -1179,8 +1179,12 @@ fi
if test "$with_bonjour" = yes ; then
AC_CHECK_HEADER(dns_sd.h, [], [AC_MSG_ERROR([header file <dns_sd.h> is required for Bonjour])])
- AC_SEARCH_LIBS(DNSServiceRefSockFD, dns_sd, [],
- [AC_MSG_ERROR([could not find function 'DNSServiceRefSockFD' required for Bonjour])])
+dnl At some point we might add something like
+dnl AC_SEARCH_LIBS(DNSServiceRegister, dns_sd)
+dnl but right now, what that would mainly accomplish is to encourage
+dnl people to try to use the avahi implementation, which does not work.
+dnl If you want to use Apple's own Bonjour code on another platform,
+dnl just add -ldns_sd to LIBS manually.
fi
# for contrib/uuid-ossp