summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorNoah Misch <noah@leadboat.com>2015-01-07 22:35:44 -0500
committerNoah Misch <noah@leadboat.com>2015-01-07 22:36:35 -0500
commit83fb1ca5cf393f3a12930bd9275a711cd858c823 (patch)
tree32ed00cbde0c67dd3015e5e6a100a7f4e9f336f3 /configure.in
parente8f82b4163edc806ecefdcfa6dfed092678218c9 (diff)
downloadpostgresql-83fb1ca5cf393f3a12930bd9275a711cd858c823.tar.gz
On Darwin, detect and report a multithreaded postmaster.
Darwin --enable-nls builds use a substitute setlocale() that may start a thread. Buildfarm member orangutan experienced BackendList corruption on account of different postmaster threads executing signal handlers simultaneously. Furthermore, a multithreaded postmaster risks undefined behavior from sigprocmask() and fork(). Emit LOG messages about the problem and its workaround. Back-patch to 9.0 (all supported versions).
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 349d4ddaf3..882d542b70 100644
--- a/configure.in
+++ b/configure.in
@@ -1280,7 +1280,7 @@ PGAC_FUNC_GETTIMEOFDAY_1ARG
LIBS_including_readline="$LIBS"
LIBS=`echo "$LIBS" | sed -e 's/-ledit//g' -e 's/-lreadline//g'`
-AC_CHECK_FUNCS([cbrt dlopen fdatasync getifaddrs getpeerucred getrlimit mbstowcs_l memmove poll pstat readlink setproctitle setsid shm_open sigprocmask symlink sync_file_range towlower utime utimes wcstombs wcstombs_l])
+AC_CHECK_FUNCS([cbrt dlopen fdatasync getifaddrs getpeerucred getrlimit mbstowcs_l memmove poll pstat pthread_is_threaded_np readlink setproctitle setsid shm_open sigprocmask symlink sync_file_range towlower utime utimes wcstombs wcstombs_l])
AC_REPLACE_FUNCS(fseeko)
case $host_os in