summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorMagnus Hagander <magnus@hagander.net>2014-07-15 18:04:43 +0200
committerMagnus Hagander <magnus@hagander.net>2014-07-15 18:07:19 +0200
commit5e4c9b37312e7d9dcb88e1e0a1fc279c780dd89e (patch)
treeedf627c2b756536c20db6d38b052403bca6569e3 /configure.in
parent77b41010dbb159b77b35aef02b517ce1a130f3b6 (diff)
downloadpostgresql-5e4c9b37312e7d9dcb88e1e0a1fc279c780dd89e.tar.gz
Detect presence of SSL_get_current_compression
Apparently we still build against OpenSSL so old that it doesn't have this function, so add an autoconf check for it to make the buildfarm happy. If the function doesn't exist, always return that compression is disabled, since presumably the actual compression functionality is always missing. For now, hardcode the function as present on MSVC, since we should hopefully be well beyond those old versions on that platform.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index c95e2cd79f..21221b336b 100644
--- a/configure.in
+++ b/configure.in
@@ -951,6 +951,7 @@ if test "$with_openssl" = yes ; then
if test "$PORTNAME" != "win32"; then
AC_CHECK_LIB(crypto, CRYPTO_new_ex_data, [], [AC_MSG_ERROR([library 'crypto' is required for OpenSSL])])
AC_CHECK_LIB(ssl, SSL_library_init, [], [AC_MSG_ERROR([library 'ssl' is required for OpenSSL])])
+ AC_CHECK_FUNCS([SSL_get_current_compression])
else
AC_SEARCH_LIBS(CRYPTO_new_ex_data, eay32 crypto, [], [AC_MSG_ERROR([library 'eay32' or 'crypto' is required for OpenSSL])])
AC_SEARCH_LIBS(SSL_library_init, ssleay32 ssl, [], [AC_MSG_ERROR([library 'ssleay32' or 'ssl' is required for OpenSSL])])