summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorAndrew Dunstan <andrew@dunslane.net>2010-12-26 10:34:47 -0500
committerAndrew Dunstan <andrew@dunslane.net>2010-12-26 10:34:47 -0500
commita534728afb7341e1ddf2df16196ed501eaa378c2 (patch)
treee3bdbb141d7234bde62eb1621260fd2819e19efb /configure.in
parent85cff3ce7f360d139d87aee836d75a6202fee066 (diff)
downloadpostgresql-a534728afb7341e1ddf2df16196ed501eaa378c2.tar.gz
Only build in crashdump support on Windows if there's a working dbghelp.h.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index b999b9481a..8ee2152d78 100644
--- a/configure.in
+++ b/configure.in
@@ -1350,6 +1350,16 @@ if test "$PORTNAME" = "win32"; then
AC_LIBOBJ(win32error)
AC_DEFINE([HAVE_SYMLINK], 1,
[Define to 1 if you have the `symlink' function.])
+ AC_CHECK_TYPES(MINIDUMP_TYPE, [pgac_minidump_type=yes], [pgac_minidump_type=no], [
+#define WIN32_LEAN_AND_MEAN
+#include <windows.h>
+#include <string.h>
+#include <dbghelp.h>])
+fi
+if test x"$pgac_minidump_type" = x"yes" ; then
+ AC_SUBST(have_win32_dbghelp,yes)
+else
+ AC_SUBST(have_win32_dbghelp,no)
fi
if test "$with_readline" = yes; then