summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorPeter Eisentraut <peter_e@gmx.net>2011-01-27 01:23:48 +0200
committerPeter Eisentraut <peter_e@gmx.net>2011-01-27 01:23:48 +0200
commit8b6f5f25102f9e2503ce18af77b6fd547a2192ca (patch)
tree6149dfb5a777b01fb57196b1471e29372205e94c /configure.in
parent6fe5e4e63ee274e66c36dce999978a3fee8cf4c6 (diff)
downloadpostgresql-8b6f5f25102f9e2503ce18af77b6fd547a2192ca.tar.gz
Use -Wformat-security when available
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 581a2198b9..e9a1b2dcba 100644
--- a/configure.in
+++ b/configure.in
@@ -429,6 +429,8 @@ if test "$GCC" = yes -a "$ICC" = no; then
# These work in some but not all gcc versions
PGAC_PROG_CC_CFLAGS_OPT([-Wdeclaration-after-statement])
PGAC_PROG_CC_CFLAGS_OPT([-Wendif-labels])
+ # This was included in -Wall/-Wformat in older GCC versions
+ PGAC_PROG_CC_CFLAGS_OPT([-Wformat-security])
# Disable strict-aliasing rules; needed for gcc 3.3+
PGAC_PROG_CC_CFLAGS_OPT([-fno-strict-aliasing])
# Disable optimizations that assume no overflow; needed for gcc 4.3+