summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorRobert Haas <rhaas@postgresql.org>2012-02-07 13:45:46 -0500
committerRobert Haas <rhaas@postgresql.org>2012-02-07 13:45:46 -0500
commit4f658dc851a73fc309a61be2503c29ed78a1592e (patch)
tree62c0e1e7bb4eb3d36313ced39615c6cda9acde11 /configure.in
parentf7d7dade8afe19847510efe44be191c35e1ce26c (diff)
downloadpostgresql-4f658dc851a73fc309a61be2503c29ed78a1592e.tar.gz
Support fls().
The immediate impetus for this is that Noah Misch's patch to elide unnecessary table and index rebuilds when changing typmod for temporal types uses it; and this is extracted from that patch, with some further commentary by me. But it seems logically separate from the remainder of the patch, so I'm committing it separately; this is not the first time someone has wanted fls() in the backend and probably won't be the last. If we end up using this in more performance-critical spots it may be worthwhile to add some architecture-specific optimizations to our src/port version of fls() - e.g. any x86 platform can implement this using the assembly instruction BSRL. But performance won't matter a bit for assessing typmod changes, so I'm not worried about that right now.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 9cad43620c..da5b11a96f 100644
--- a/configure.in
+++ b/configure.in
@@ -1335,7 +1335,7 @@ fi
pgac_save_LIBS="$LIBS"
LIBS=`echo "$LIBS" | sed -e 's/-ledit//g' -e 's/-lreadline//g'`
-AC_REPLACE_FUNCS([crypt getopt getrusage inet_aton random rint srandom strdup strerror strlcat strlcpy strtol strtoul])
+AC_REPLACE_FUNCS([crypt fls getopt getrusage inet_aton random rint srandom strdup strerror strlcat strlcpy strtol strtoul])
case $host_os in