summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorTom Lane <tgl@sss.pgh.pa.us>2009-09-08 16:08:26 +0000
committerTom Lane <tgl@sss.pgh.pa.us>2009-09-08 16:08:26 +0000
commit59b9f3d36d56fa2bc998c4169f650b0a501874ea (patch)
tree711d368eff299a53b540dba9d0eec549f8104071 /configure.in
parent4d3456e85dabfbe4182f94178ecb8789d9592bf7 (diff)
downloadpostgresql-59b9f3d36d56fa2bc998c4169f650b0a501874ea.tar.gz
Replace use of the long-deprecated Bonjour API DNSServiceRegistrationCreate
with the not-so-deprecated DNSServiceRegister. This patch shouldn't change any user-visible behavior, it just gets rid of a deprecation warning in --with-bonjour builds. The new code will fail on OS X releases before 10.3, but it seems unlikely that anyone will want to run Postgres 8.5 on 10.2.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 5cd5d13725..fe76ea1daf 100644
--- a/configure.in
+++ b/configure.in
@@ -1,5 +1,5 @@
dnl Process this file with autoconf to produce a configure script.
-dnl $PostgreSQL: pgsql/configure.in,v 1.609 2009/08/26 22:24:42 petere Exp $
+dnl $PostgreSQL: pgsql/configure.in,v 1.610 2009/09/08 16:08:26 tgl Exp $
dnl
dnl Developers, please strive to achieve this order:
dnl
@@ -1066,7 +1066,7 @@ if test "$with_ldap" = yes ; then
fi
if test "$with_bonjour" = yes ; then
- AC_CHECK_HEADER(DNSServiceDiscovery/DNSServiceDiscovery.h, [], [AC_MSG_ERROR([header file <DNSServiceDiscovery/DNSServiceDiscovery.h> is required for Bonjour])])
+ AC_CHECK_HEADER(dns_sd.h, [], [AC_MSG_ERROR([header file <dns_sd.h> is required for Bonjour])])
fi
# for contrib/uuid-ossp