summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorTom Lane <tgl@sss.pgh.pa.us>2006-10-03 22:18:23 +0000
committerTom Lane <tgl@sss.pgh.pa.us>2006-10-03 22:18:23 +0000
commit6edd2b4a91bda90b7f0290203bf5c88a8a8504db (patch)
treec0890bc97d0e2d1e1c92b9b883150a91995dbc89 /configure.in
parented80f5701be9322d319a4abaef0e4f47f6144f5b (diff)
downloadpostgresql-6edd2b4a91bda90b7f0290203bf5c88a8a8504db.tar.gz
Switch over to using our own qsort() all the time, as has been proposed
repeatedly. Now that we don't have to worry about memory leaks from glibc's qsort, we can safely put CHECK_FOR_INTERRUPTS into the tuplesort comparators, as was requested a couple months ago. Also, get rid of non-reentrancy and an extra level of function call in tuplesort.c by providing a variant qsort_arg() API that passes an extra void * argument through to the comparison routine. (We might want to use that in other places too, I didn't look yet.)
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in10
1 files changed, 1 insertions, 9 deletions
diff --git a/configure.in b/configure.in
index d3764a4542..42b2579fbb 100644
--- a/configure.in
+++ b/configure.in
@@ -1,5 +1,5 @@
dnl Process this file with autoconf to produce a configure script.
-dnl $PostgreSQL: pgsql/configure.in,v 1.478 2006/10/02 00:06:18 tgl Exp $
+dnl $PostgreSQL: pgsql/configure.in,v 1.479 2006/10/03 22:18:22 tgl Exp $
dnl
dnl Developers, please strive to achieve this order:
dnl
@@ -986,14 +986,6 @@ case $host_os in bsdi*|netbsd*)
ac_cv_func_fseeko=yes
esac
-# Solaris has a very slow qsort in certain cases, so we replace it:
-# http://forum.sun.com/thread.jspa?forumID=4&threadID=7231
-# Supposedly it is fixed in Solaris, but not sure which version, and
-# no confirmed testing. 2005-12-16
-if test "$PORTNAME" = "solaris"; then
-AC_LIBOBJ(qsort)
-fi
-
# Win32 support
if test "$PORTNAME" = "win32"; then
AC_LIBOBJ(gettimeofday)