summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorTom Lane <tgl@sss.pgh.pa.us>2005-08-02 19:02:32 +0000
committerTom Lane <tgl@sss.pgh.pa.us>2005-08-02 19:02:32 +0000
commit558730ac6bbc668a75c7a7619beae5a1b34d965f (patch)
treed8928d1a5e9e5aefa53a6f96fd7d9237d40e872e /configure.in
parent0001e98d54f3d81c2ff413e4aec4933bd1378963 (diff)
downloadpostgresql-558730ac6bbc668a75c7a7619beae5a1b34d965f.tar.gz
Clean up CREATE DATABASE processing to make it more robust and get rid
of special case for Windows port. Put a PG_TRY around most of createdb() to ensure that we remove copied subdirectories on failure, even if the failure happens while creating the pg_database row. (I think this explains Oliver Siegmar's recent report.) Having done that, there's no need for the fragile assumption that copydir() mustn't ereport(ERROR), so simplify its API. Eliminate the old code that used system("cp ...") to copy subdirectories, in favor of using copydir() on all platforms. This not only should allow much better error reporting, but allows us to fsync the created files before trusting that the copy has succeeded.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in3
1 files changed, 1 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 3baed6c79f..8eb5c91e2c 100644
--- a/configure.in
+++ b/configure.in
@@ -1,5 +1,5 @@
dnl Process this file with autoconf to produce a configure script.
-dnl $PostgreSQL: pgsql/configure.in,v 1.417 2005/07/06 21:04:13 momjian Exp $
+dnl $PostgreSQL: pgsql/configure.in,v 1.418 2005/08/02 19:02:30 tgl Exp $
dnl
dnl Developers, please strive to achieve this order:
dnl
@@ -913,7 +913,6 @@ fi
# Win32 support
if test "$PORTNAME" = "win32"; then
-AC_LIBOBJ(copydir)
AC_LIBOBJ(gettimeofday)
AC_LIBOBJ(kill)
AC_LIBOBJ(open)