summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorTom Lane <tgl@sss.pgh.pa.us>2004-09-02 15:39:56 +0000
committerTom Lane <tgl@sss.pgh.pa.us>2004-09-02 15:39:56 +0000
commit3a6f1313b58988bb94f848f74d917ffa886aecef (patch)
tree8dc8b84d09695d7f1f959048678b5110fa760002 /configure.in
parentbaace400c75392b2bfca71e53c212d7bdac36702 (diff)
downloadpostgresql-3a6f1313b58988bb94f848f74d917ffa886aecef.tar.gz
Use $PATH_SEPARATOR like the rest of the autoconf code, instead of
hardwiring IFS=: when searching paths.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index 3e3c93757c..b95b001dcd 100644
--- a/configure.in
+++ b/configure.in
@@ -1,5 +1,5 @@
dnl Process this file with autoconf to produce a configure script.
-dnl $PostgreSQL: pgsql/configure.in,v 1.374 2004/08/31 04:08:33 pgsql Exp $
+dnl $PostgreSQL: pgsql/configure.in,v 1.375 2004/09/02 15:39:56 tgl Exp $
dnl
dnl Developers, please strive to achieve this order:
dnl
@@ -326,7 +326,7 @@ PGAC_ARG_BOOL(enable, cassert, no, [ --enable-cassert enable assertion c
# Include directories
#
ac_save_IFS=$IFS
-IFS="${IFS}:"
+IFS="${IFS}${PATH_SEPARATOR}"
# SRCH_INC comes from the template file
for dir in $with_includes $SRCH_INC; do
if test -d "$dir"; then
@@ -343,7 +343,7 @@ AC_SUBST(INCLUDES)
# Library directories
#
ac_save_IFS=$IFS
-IFS="${IFS}:"
+IFS="${IFS}${PATH_SEPARATOR}"
# LIBRARY_DIRS comes from command line, SRCH_LIB from template file.
for dir in $LIBRARY_DIRS $SRCH_LIB; do
if test -d "$dir"; then