summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorTom Lane <tgl@sss.pgh.pa.us>2001-08-01 23:25:39 +0000
committerTom Lane <tgl@sss.pgh.pa.us>2001-08-01 23:25:39 +0000
commitbc042e0a775040927b194473b4abf9c48e56d0a5 (patch)
tree081de4fd0d17366b5f7f15cd49fdd175ae75ed24 /configure.in
parent7208518720260735b7c8b1c27f34e5fe08951241 (diff)
downloadpostgresql-bc042e0a775040927b194473b4abf9c48e56d0a5.tar.gz
Support ident authentication on local (Unix) socket connections, if the
system supports SO_PEERCRED requests for Unix sockets. This is an amalgamation of patches submitted by Helge Bahmann and Oliver Elphick, with some editorializing by yours truly.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in13
1 files changed, 13 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 076fd8a0fd..c9af97065f 100644
--- a/configure.in
+++ b/configure.in
@@ -801,6 +801,19 @@ AC_CHECK_FUNCS([fcvt getopt_long memmove pstat setproctitle setsid sigprocmask s
dnl Check whether <unistd.h> declares fdatasync().
AC_EGREP_HEADER(fdatasync, unistd.h, AC_DEFINE(HAVE_FDATASYNC_DECL))
+AC_MSG_CHECKING([for SO_PEERCRED])
+AC_EGREP_CPP(HAVE_SO_PEERCRED,
+#include <sys/socket.h>
+#ifdef SO_PEERCRED
+HAVE_SO_PEERCRED
+#endif
+],
+[
+ AC_MSG_RESULT(yes)
+ AC_DEFINE(HAVE_SO_PEERCRED)
+],
+[AC_MSG_RESULT(no)])
+
AC_CACHE_CHECK([for PS_STRINGS], [pgac_cv_var_PS_STRINGS],
[AC_TRY_LINK(
[#include <machine/vmparam.h>