summaryrefslogtreecommitdiff
path: root/src/polkitagent/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/polkitagent/Makefile.am')
-rw-r--r--src/polkitagent/Makefile.am10
1 files changed, 6 insertions, 4 deletions
diff --git a/src/polkitagent/Makefile.am b/src/polkitagent/Makefile.am
index e8c9fb1..1cfb73c 100644
--- a/src/polkitagent/Makefile.am
+++ b/src/polkitagent/Makefile.am
@@ -5,6 +5,7 @@ INCLUDES = \
-I$(top_srcdir)/src \
-I$(top_builddir)/src/polkit \
-I$(top_srcdir)/src/polkit \
+ -DPACKAGE_PREFIX=\""$(prefix)"\" \
-DPACKAGE_LIBEXEC_DIR=\""$(libexecdir)"\" \
-DPACKAGE_SYSCONF_DIR=\""$(sysconfdir)"\" \
-DPACKAGE_DATA_DIR=\""$(datadir)"\" \
@@ -77,7 +78,8 @@ libpolkit_agent_1_la_LIBADD = \
libpolkit_agent_1_la_LDFLAGS = -export-symbols-regex '(^polkit_.*)'
-libexec_PROGRAMS = polkit-agent-helper-1
+libprivdir = $(prefix)/lib/polkit-1
+libpriv_PROGRAMS = polkit-agent-helper-1
polkit_agent_helper_1_SOURCES = \
polkitagenthelperprivate.c polkitagenthelperprivate.h \
@@ -132,9 +134,9 @@ endif # HAVE_INTROSPECTION
# authenticate not only the invoking user, but possibly also root
# and/or other users.
#
-install-exec-hook:
- -chown root $(DESTDIR)$(libexecdir)/polkit-agent-helper-1
- -chmod 4755 $(DESTDIR)$(libexecdir)/polkit-agent-helper-1
+install-data-hook:
+ -chown root $(DESTDIR)$(libprivdir)/polkit-agent-helper-1
+ -chmod 4755 $(DESTDIR)$(libprivdir)/polkit-agent-helper-1
EXTRA_DIST = polkitagentmarshal.list polkitagentenumtypes.h.template polkitagentenumtypes.c.template