summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid Zeuthen <zeuthen@gmail.com>2012-06-06 14:32:26 -0400
committerDavid Zeuthen <zeuthen@gmail.com>2012-06-06 14:32:26 -0400
commit3d007cbc5d4a1560cdcca08b5ca0401371fc7b77 (patch)
treee28c5dd7ee568b33f4bc1211d36c8a563637ad3d /configure.ac
parent14121fda7e4fa9463c66ce419cc32be7e7f3b535 (diff)
downloadpolkit-3d007cbc5d4a1560cdcca08b5ca0401371fc7b77.tar.gz
Make it work when using ConsoleKit instead of libsystemd-login
... although it would be nicer to just rip out the CK bits and simply hard-require libsystemd-login instead - it should work just fine on non-systemd systems, same way systemd-udev works fine there. Signed-off-by: David Zeuthen <zeuthen@gmail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 4cb7329..326646c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -169,6 +169,7 @@ if test "$enable_libsystemd_login" != "no"; then
have_libsystemd_login=no)
if test "$have_libsystemd_login" = "yes"; then
SESSION_TRACKING=libsystemd-login
+ AC_DEFINE([HAVE_LIBSYSTEMD_LOGIN], 1, [Define to 1 if libsystemd-login is available])
else
if test "$enable_libsystemd_login" = "yes"; then
AC_MSG_ERROR([libsystemd-login support requested but libsystemd-login library not found])