summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 7 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 0e58512..9c224ac 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -24,6 +24,7 @@ endif
AM_CFLAGS = \
$(WARN_CFLAGS) \
+ $(GCOV_CFLAGS) \
$(GLIB_CFLAGS)
bin_PROGRAMS = pkg-config
@@ -42,6 +43,12 @@ dist_doc_DATA = pkg-config-guide.html
dist_man_MANS = pkg-config.1
EXTRA_DIST = README.win32
+# gcov test coverage
+gcov:
+ -$(MAKE) $(AM_MAKEFLAGS) -k check
+ $(GCOV) $(pkg_config_SOURCES)
+CLEANFILES = *.gcda *.gcno *.gcov
+
# Since we can't always have glib in DIST_SUBDIRS, we need to make sure
# glib is configured when we want to run dist. Unfortunately, there's no
# DIST_CONFIGURE_FLAGS.