summaryrefslogtreecommitdiff
path: root/pidgin/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'pidgin/Makefile.am')
-rw-r--r--pidgin/Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/pidgin/Makefile.am b/pidgin/Makefile.am
index d0c2d69cd5..0d19e149b7 100644
--- a/pidgin/Makefile.am
+++ b/pidgin/Makefile.am
@@ -3,6 +3,7 @@ EXTRA_DIST = \
getopt.h \
getopt1.c \
Makefile.mingw \
+ data/pidgin.appdata.xml.in \
data/pidgin.desktop.in \
data/pidgin.pc.in \
data/pidgin-uninstalled.pc.in \
@@ -186,8 +187,16 @@ appsdir = $(datadir)/applications
apps_in_files = data/pidgin.desktop.in
apps_DATA = $(apps_in_files:.desktop.in=.desktop)
@INTLTOOL_DESKTOP_RULE@
+
+appdatadir = $(datarootdir)/appdata
+appdata_DATA = $(appdata_in_files:.xml.in=.xml)
+appdata_in_files = data/pidgin.appdata.xml.in
+
+@INTLTOOL_XML_RULE@
+
endif # INSTALL_I18N
+CLEANFILES = $(appdata_DATA)
DISTCLEANFILES = $(DESKTOP_FILE)
endif # ENABLE_GTK